PKI Packages

From Dogtag
Revision as of 00:14, 4 May 2010 by Mharmsen (talk | contribs) (PKI Component Packages)

Jump to: navigation, search

PKI Component Packages

IMPORTANT: For ALL of the following components, "{flavor}" equals "dogtag"!

The following table lists all PKI component packages with a brief description of their purpose along with their Fedora/EPEL build and runtime dependencies:

PKI Component Description Fedora/EPEL Build Dependencies Fedora/EPEL Runtime Dependencies

osutil

A Java Native Interface (JNI) library composed of operating system utilities - PKI subsystems only utilize the various Base64 and getpid() functions

ant,
java-devel >= 1:1.6.0,
jpackage-utils,
nspr-devel >= 4.6.99,
nss-devel >= 3.12.3.99,
pkgconfig

java >= 1:1.6.0,
jpackage-utils,
nss >= 3.12.3.99

pki-symkey

A Java Native Interface (JNI) library composed of symmetric key functions

NOTE:   Prior to Dogtag 1.3, the 'pki-symkey' RPM was simply called 'symkey'!

ant,
java-devel >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6,
nspr-devel >= 4.6.99,
nss-devel >= 3.12.3.99,
pkgconfig

java >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6,
nss >= 3.12.3.99

pki-util

Low-level PKI utilities

ant,
java-devel >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6,
ldapjdk,
osutil,
xerces-j2

java >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6,
ldapjdk

pki-native-tools

Various stand-alone PKI tools created from C, C++, Perl, bash, etc. See PKI Native Tools for more information.

bash >= 3.0,
cyrus-sasl-devel >= 2.1.19,
mozldap-devel >= 6.0.2,
nspr-devel >= 4.6.5,
nss-devel >= 3.11.5,
nss-pkcs11-devel >= 3.11.5,
svrcore-devel >= 4.0.3.01

mozldap-tools >= 6.0.2,
nss >= 3.11.5,
nss-tools >= 3.11.5

pki-setup

Perl scripts intended for management of CA, DRM, OCSP, RA, TKS, and TPS subsystem instances

ant >= 1.6.2

pki-native-tools >= 1.0.0,
perl >= 5.8.0

pki-java-tools

Various PKI tools created as stand-alone Java applications. See PKI Java Tools for more information.

ant >= 1.6.2,
pki-util >= 1.0.0,
java-devel >= 1.4.2,
jpackage-utils >= 1.6.0,
jss >= 4.2.4

pki-native-tools >= 1.0.0,
pki-util >= 1.0.0,
java >= 1.4.2

pki-selinux

Selinux policies used by the PKI components.

ant >= 1.6.2
selinux-policy-devel
m4
make
policycoreutils

policycoreutils
libsemanage

{flavor}-pki-common-ui

User interface "flavor" for pki-common component
Provides: pki-common-ui

ant >= 1.6.2

bash >= 3.0

pki-common

Common PKI functions shared by the CA, DRM, OCSP, and TKS subsystems

ant >= 1.6.2,
pki-util >= 1.0.0,
pki-common-ui >= 1.0.0,
java-devel >= 1.4.2,
jpackage-utils >= 1.6.0,
jss >= 4.2.4,
ldapjdk >= 4.17,
osutil >= 1.0.0,
symkey >= 1.0.0 (pki-symkey >= 1.3.0),
velocity >= 1.4

pki-common-ui,
pki-java-tools >= 1.0.0,
pki-setup >= 1.0.0,
java >= 1.4.2,
osutil >= 1.0.0,
rhgb >= 0.14.1,
symkey >= 1.0.0 (pki-symkey >= 1.3.0),
tomcatjss >= 1.1.0,
velocity >= 1.4

{flavor}-pki-ca-ui

User interface "flavor" for pki-ca component
Provides: pki-ca-ui

ant >= 1.6.2

bash >= 3.0

pki-ca

Certificate Authority

ant >= 1.6.2,
pki-ca-ui >= 1.0.0,
pki-common >= 1.0.0,
pki-util >= 1.0.0,
java-devel >= 1.4.2,
jpackage-utils >= 1.6.0,
jss >= 4.2.4

pki-ca-ui,
pki-common >= 1.0.0
pki-selinux >= 1.0.0

{flavor}-pki-kra-ui

User interface "flavor" for pki-kra component
Provides: pki-kra-ui

ant >= 1.6.2

bash >= 3.0

pki-kra

Data Recovery Manager

ant >= 1.6.2,
pki-kra-ui >= 1.0.0,
pki-common >= 1.0.0,
pki-util >= 1.0.0,
java-devel >= 1.4.2,
jpackage-utils >= 1.6.0,
jss >= 4.2.4

pki-kra-ui,
pki-common >= 1.0.0
pki-selinux >= 1.0.0

{flavor}-pki-ocsp-ui

User interface "flavor" for pki-ocsp component
Provides: pki-ocsp-ui

ant >= 1.6.2

bash >= 3.0

pki-ocsp

Online Certificate Status Protocol Manager

ant >= 1.6.2,
pki-ocsp-ui >= 1.0.0,
pki-common >= 1.0.0,
pki-util >= 1.0.0,
java-devel >= 1.4.2,
jpackage-utils >= 1.6.0,
jss >= 4.2.4

pki-ocsp-ui,
pki-common >= 1.0.0
pki-selinux >= 1.0.0

{flavor}-pki-tks-ui

User interface "flavor" for pki-tks component
Provides: pki-tks-ui

ant >= 1.6.2

bash >= 3.0

pki-tks

Token Key Service for Smartcards

ant >= 1.6.2,
pki-tks-ui >= 1.0.0,
pki-common >= 1.0.0,
pki-util >= 1.0.0,
java-devel >= 1.4.2,
jpackage-utils >= 1.6.0,
jss >= 4.2.4

pki-tks-ui,
pki-common >= 1.0.0
pki-selinux >= 1.0.0

{flavor}-pki-ra-ui

User interface "flavor" for ra component
Provides: pki-ra-ui

ant >= 1.6.2

bash >= 3.0

pki-ra

Registration Authority

ant >= 1.6.2,
pki-ra-ui >= 1.0.0

pki-ra-ui,
pki-setup >= 1.0.0,
mod_nss >= 1.0.3,
mod_perl >= 1.99_16,
mozldap >= 6.0.2,
perl-DBD-SQLite >= 1.11,
perl-HTML-Parser >= 3.35,
perl-HTML-Tagset >= 3.03,
perl-Parse-RecDescent >= 1.94,
perl-URI >= 1.30,
perl-XML-NamespaceSupport >= 1.08,
perl-XML-Parser >= 2.34,
perl-XML-SAX >= 0.12,
perl-XML-Simple >= 2.14,
perl-libwww-perl >= 5.79,
sendmail >= 8.13.1,
sqlite >= 3.3.3
pki-selinux > 1.0.0

{flavor}-pki-tps-ui

User interface "flavor" for tps component
Provides: pki-tps-ui

ant >= 1.6.2

bash >= 3.0

pki-tps

Token Processing System for Smartcards

apr-devel >= 0.9.4,
apr-util-devel >= 0.9.4,
pki-tps-ui >= 1.0.0,
bash >= 3.0,
cyrus-sasl-devel >= 2.1.19,
httpd-devel >= 2.0.52,
mozldap-devel >= 6.0.2,
nspr-devel >= 4.6.5,
nss-devel >= 3.11.5,
nss-pkcs11-devel >= 3.11.5,
pcre-devel >= 6.6,
svrcore-devel >= 4.0.3.01,
zlib >= 1.2.3

pki-setup >= 1.0.0,
pki-tps-ui,
mod_nss >= 1.0.3,
mod_perl >= 1.99_16,
mozldap >= 6.0.2,
perl-HTML-Parser >= 3.35,
perl-HTML-Tagset >= 3.03,
perl-Parse-RecDescent >= 1.94,
perl-URI >= 1.30,
perl-XML-NamespaceSupport >= 1.08,
perl-XML-Parser >= 2.34,
perl-XML-SAX >= 0.12,
perl-XML-Simple >= 2.14,
perl-libwww-perl >= 5.79
pki-selinux >= 1.0.0

pki-manage

Perl scripts intended for management of CA, DRM, OCSP, RA, TKS, and TPS subsystems

NOTE:   As of Dogtag 1.3, the 'pki-manage' RPM has been 'discontinued' on Fedora/EPEL platforms in favor of 'yum' and 'yum-utils'!

ant >= 1.6.2

perl >= 5.8.0

{flavor}-pki-console-ui

User interface "flavor" for pki-console component
Provides: pki-console-ui

ant >= 1.6.2,
java-devel >= 1.4.2,
jpackage-utils >= 1.6.0,
jss >= 4.2.4,
ldapjdk >= 4.17

jss >= 4.2.4,
ldapjdk >= 4.17

pki-console

PKI console for management of the CA, DRM, OCSP, and TKS subsystems

ant >= 1.6.2,
pki-util >= 1.0.0,
pki-console-ui >= 1.0.0,
idm-console-framework >= 1.0.3,
jpackage-utils >= 1.6.0,
jss >= 4.2.4,
ldapjdk >= 4.17,
java-sdk >= 1.7.0

pki-console-ui,
idm-console-framework >= 1.0.3,
jss >= 4.2.4,
ldapjdk >= 4.17

pki-silent

Java utility used for batch configuration of CA, DRM, OCSP, TKS, RA, and TPS subsystem instances

ant >= 1.6.2,
pki-common >= 1.0.0,
pki-util >= 1.0.0,
java-devel >= 1.4.2,
jpackage-utils >= 1.6.0,
jss >= 4.2.4

pki-common >= 1.0.0

pki-migrate

Pre-built applications created to migrate data between various versions of Certificate System

NOTE:   As of Dogtag 1.3, the 'pki-migrate' RPM has been 'discontinued'!

N/A

java