Difference between revisions of "PKI Packages"

From Dogtag
Jump to: navigation, search
(PKI Component Packages)
(PKI Component Packages)
Line 1: Line 1:
 
== PKI Component Packages ==
 
== PKI Component Packages ==
 +
 +
=== Dogtag 9.0 ===
 +
 +
The following table lists all PKI component packages with a brief description of their purpose along with their Fedora/EPEL build and runtime dependencies:
 +
 +
<table border=1>
 +
<tr>
 +
<th width="20%">PKI Component</th>
 +
<th width="40%">Description</th>
 +
<th width="20%">Fedora/EPEL Build Dependencies</th>
 +
<th width="20%">Fedora/EPEL Runtime Dependencies</th>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
osutil
 +
</th>
 +
<td valign="top">
 +
A Java Native Interface (JNI) library composed of operating system utilities - PKI subsystems only utilize the various Base64 and getpid() functions
 +
</td>
 +
<td valign="top">
 +
ant,<br>
 +
java-devel >= 1:1.6.0,<br>
 +
jpackage-utils,<br>
 +
nspr-devel >= 4.6.99,<br>
 +
nss-devel >= 3.12.3.99,<br>
 +
pkgconfig
 +
</td>
 +
<td valign="top">
 +
java >= 1:1.6.0,<br>
 +
jpackage-utils,<br>
 +
nss >= 3.12.3.99
 +
</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
osutil-debuginfo
 +
</th>
 +
<td valign="top">
 +
'osutil' subpackage for debugging.
 +
</td>
 +
<td valign="top">&nbsp;</td>
 +
<td valign="top">&nbsp;</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
pki-symkey<br>
 +
</th>
 +
<td valign="top">
 +
A Java Native Interface (JNI) library composed of symmetric key functions
 +
 +
<table>
 +
<tr>
 +
<td valign="top">'''<font color="RED">NOTE:&nbsp;&nbsp;</font>'''</td>
 +
<td>'''<font color="RED">Prior to Dogtag 1.3, the 'pki-symkey' RPM was simply called 'symkey' and contained no subpackages!</font>'''</td>
 +
</tr>
 +
</table>
 +
</td>
 +
<td valign="top">
 +
ant,<br>
 +
java-devel >= 1:1.6.0,<br>
 +
jpackage-utils,<br>
 +
jss >= 4.2.6,<br>
 +
nspr-devel >= 4.6.99,<br>
 +
nss-devel >= 3.12.3.99,<br>
 +
pkgconfig
 +
</td>
 +
<td valign="top">
 +
java >= 1:1.6.0,<br>
 +
jpackage-utils,<br>
 +
jss >= 4.2.6,<br>
 +
nss >= 3.12.3.99
 +
</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
pki-symkey-debuginfo
 +
</th>
 +
<td valign="top">
 +
'pki-symkey' subpackage for debugging.
 +
</td>
 +
<td valign="top">&nbsp;</td>
 +
<td valign="top">&nbsp;</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
pki-native-tools
 +
</th>
 +
<td valign="top">
 +
Various stand-alone PKI tools created from C, C++, Perl, bash, etc.  See [[PKI Native Tools]] for more information.
 +
</td>
 +
<td valign="top">
 +
cyrus-sasl-devel,<br>
 +
mozldap-devel,<br>
 +
nspr-devel >= 4.6.99,<br>
 +
nss-devel >= 3.12.3.99,<br>
 +
svrcore-devel
 +
</td>
 +
<td valign="top">
 +
mozldap-tools,<br>
 +
nss >= 3.12.3.99,<br>
 +
nss-tools >= 3.12.3.99
 +
</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
pki-native-tools-debug
 +
</th>
 +
<td valign="top">
 +
'pki-native-tools' subpackage for debugging.
 +
</td>
 +
<td valign="top">&nbsp;</td>
 +
<td valign="top">&nbsp;</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
pki-util
 +
</th>
 +
<td valign="top">
 +
Low-level PKI utilities
 +
</td>
 +
<td valign="top">
 +
ant,<br>
 +
java-devel >= 1:1.6.0,<br>
 +
jpackage-utils,<br>
 +
jss >= 4.2.6,<br>
 +
ldapjdk,<br>
 +
osutil,<br>
 +
xerces-j2
 +
</td>
 +
<td valign="top">
 +
java >= 1:1.6.0,<br>
 +
jpackage-utils,<br>
 +
jss >= 4.2.6,<br>
 +
ldapjdk
 +
</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
pki-util-javadoc
 +
</th>
 +
<td valign="top">
 +
'pki-util' Javadocs.
 +
</td>
 +
<td valign="top">&nbsp;</td>
 +
<td valign="top">%{name} = %{version}-%{release}</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
pki-setup
 +
</th>
 +
<td valign="top">
 +
Perl scripts intended for management of CA, DRM, OCSP, RA, TKS, and TPS subsystem instances
 +
</td>
 +
<td valign="top">
 +
ant
 +
</td>
 +
<td valign="top">
 +
perl-Crypt-SSLeay,<br>
 +
policycoreutils,<br>
 +
%{?fc11:policycoreutils-python},<br>
 +
%{?fc12:policycoreutils-python}
 +
</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
pki-java-tools
 +
</th>
 +
<td valign="top">
 +
Various PKI tools created as stand-alone Java applications.  See [[PKI Java Tools]] for more information.
 +
</td>
 +
<td valign="top">
 +
ant,<br>
 +
java-devel >= 1:1.6.0,<br>
 +
jpackage-utils,<br>
 +
jss >= 4.2.6,<br>
 +
osutil,<br>
 +
pki-util
 +
</td>
 +
<td valign="top">
 +
java >= 1:1.6.0,<br>
 +
pki-native-tools,<br>
 +
pki-util
 +
</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
pki-java-tools-javadoc
 +
</th>
 +
<td valign="top">
 +
'pki-java-tools' Javadocs.
 +
</td>
 +
<td valign="top">&nbsp;</td>
 +
<td valign="top">%{name} = %{version}-%{release}</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
{flavor}-pki-common-ui
 +
</th>
 +
<td valign="top">
 +
User interface "flavor" for pki-common component<br>Provides:  pki-common-ui
 +
</td>
 +
<td valign="top">
 +
ant
 +
</td>
 +
<td valign="top">&nbsp;</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
pki-common
 +
</th>
 +
<td valign="top">
 +
Common PKI functions shared by the CA, DRM, OCSP, and TKS subsystems
 +
</td>
 +
<td valign="top">
 +
ant,<br>
 +
java-devel >= 1:1.6.0,<br>
 +
jpackage-utils,<br>
 +
jss >= 4.2.6,<br>
 +
ldapjdk,<br>
 +
osutil,<br>
 +
pki-symkey,<br>
 +
pki-util,<br>
 +
velocity,<br>
 +
xalan-j2
 +
</td>
 +
<td valign="top">
 +
java >= 1:1.6.0,<br>
 +
jss >= 4.2.6,<br>
 +
osutil,<br>
 +
pki-common-ui,<br>
 +
pki-java-tools,<br>
 +
pki-setup,<br>
 +
pki-symkey,<br>
 +
tomcatjss,<br>
 +
%{_javadir}/ldapjdk.jar,<br>
 +
%{_javadir}/velocity.jar,<br>
 +
%{_javadir}/xalan-j2.jar,<br>
 +
%{_javadir}/xerces-j2.jar,<br>
 +
velocity
 +
</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
pki-common-javadoc
 +
</th>
 +
<td valign="top">
 +
'pki-common' Javadocs.
 +
</td>
 +
<td valign="top">&nbsp;</td>
 +
<td valign="top">pki-common = %{version}-%{release}</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
{flavor}-pki-console-ui
 +
</th>
 +
<td valign="top">
 +
User interface "flavor" for pki-console component<br>Provides:  pki-console-ui
 +
</td>
 +
<td valign="top">
 +
ant,<br>
 +
java-devel >= 1:1.6.0,<br>
 +
jpackage-utils,<br>
 +
jss >= 4.2.6,<br>
 +
ldapjdk
 +
</td>
 +
<td valign="top">
 +
java >= 1:1.6.0,<br>
 +
jss >= 4.2.6,<br>
 +
ldapjdk
 +
</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
pki-console
 +
</th>
 +
<td valign="top">
 +
PKI console for management of the CA, DRM, OCSP, and TKS subsystems
 +
</td>
 +
<td valign="top">
 +
ant,<br>
 +
idm-console-framework,<br>
 +
java-devel >= 1:1.6.0,<br>
 +
jpackage-utils,<br>
 +
jss >= 4.2.6,<br>
 +
ldapjdk,<br>
 +
pki-util
 +
</td>
 +
<td valign="top">
 +
idm-console-framework,<br>
 +
java >= 1:1.6.0,<br>
 +
jss >= 4.2.6,<br>
 +
ldapjdk,<br>
 +
pki-console-ui
 +
</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
pki-selinux
 +
</th>
 +
<td valign="top">
 +
Selinux policies used by the PKI components.
 +
</td>
 +
<td valign="top">
 +
ant,<br>
 +
m4,<br>
 +
make,<br>
 +
policycoreutils,<br>
 +
selinux-policy-devel
 +
</td>
 +
<td valign="top">
 +
policycoreutils,<br>
 +
selinux-policy-targeted
 +
</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
pki-silent
 +
</th>
 +
<td valign="top">
 +
Java utility used for batch configuration of CA, DRM, OCSP, TKS, RA, and TPS subsystem instances
 +
</td>
 +
<td valign="top">
 +
ant,<br>
 +
java-devel >= 1:1.6.0,<br>
 +
jpackage-utils,<br>
 +
jss >= 4.2.6,<br>
 +
pki-common,<br>
 +
pki-util
 +
</td>
 +
<td valign="top">
 +
java >= 1:1.6.0,<br>
 +
pki-common
 +
</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
{flavor}-pki-ca-ui
 +
</th>
 +
<td valign="top">
 +
User interface "flavor" for pki-ca component<br>Provides:  pki-ca-ui
 +
</td>
 +
<td valign="top">
 +
ant
 +
</td>
 +
<td valign="top">&nbsp;</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
pki-ca
 +
</th>
 +
<td valign="top">
 +
Certificate Authority
 +
</td>
 +
<td valign="top">
 +
ant,<br>
 +
java-devel >= 1:1.6.0,<br>
 +
jpackage-utils,<br>
 +
jss >= 4.2.6,<br>
 +
pki-common,<br>
 +
pki-util,<br>
 +
tomcatjss
 +
</td>
 +
<td valign="top">
 +
java >= 1:1.6.0,<br>
 +
pki-ca-ui,<br>
 +
pki-common,<br>
 +
pki-console,<br>
 +
pki-selinux,<br>
 +
pki-silent,<br>
 +
(post):chkconfig,<br>
 +
(preun):chkconfig,<br>
 +
(preun):initscripts,<br>
 +
(postun):initscripts
 +
</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
{flavor}-pki-kra-ui
 +
</th>
 +
<td valign="top">
 +
User interface "flavor" for pki-kra component<br>Provides:  pki-kra-ui
 +
</td>
 +
<td valign="top">
 +
ant
 +
</td>
 +
<td valign="top">&nbsp;</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
pki-kra
 +
</th>
 +
<td valign="top">
 +
Data Recovery Manager
 +
</td>
 +
<td valign="top">
 +
ant,<br>
 +
java-devel >= 1:1.6.0,<br>
 +
jpackage-utils,<br>
 +
jss >= 4.2.6,<br>
 +
pki-common,<br>
 +
pki-util,<br>
 +
tomcatjss
 +
</td>
 +
<td valign="top">
 +
java >= 1:1.6.0,<br>
 +
pki-common,<br>
 +
pki-console,<br>
 +
pki-kra-ui,<br>
 +
pki-selinux,<br>
 +
pki-silent,<br>
 +
(post):chkconfig,<br>
 +
(preun):chkconfig,<br>
 +
(preun):initscripts,<br>
 +
(postun):initscripts
 +
</td>
 +
</tr>
 +
 +
 +
 +
<tr>
 +
<th valign="top">
 +
{flavor}-pki-ocsp-ui
 +
</th>
 +
<td valign="top">
 +
User interface "flavor" for pki-ocsp component<br>Provides:  pki-ocsp-ui
 +
</td>
 +
<td valign="top">
 +
ant
 +
</td>
 +
<td valign="top">&nbsp;</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
pki-ocsp
 +
</th>
 +
<td valign="top">
 +
Online Certificate Status Protocol Manager
 +
</td>
 +
<td valign="top">
 +
ant,<br>
 +
java-devel >= 1:1.6.0,<br>
 +
jpackage-utils,<br>
 +
jss >= 4.2.6,<br>
 +
pki-common,<br>
 +
pki-util,<br>
 +
tomcatjss
 +
</td>
 +
<td valign="top">
 +
java >= 1:1.6.0,<br>
 +
pki-common,<br>
 +
pki-console,<br>
 +
pki-ocsp-ui,<br>
 +
pki-selinux,<br>
 +
pki-silent,<br>
 +
(post):chkconfig,<br>
 +
(preun):chkconfig,<br>
 +
(preun):initscripts,<br>
 +
(postun):initscripts
 +
</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
{flavor}-pki-tks-ui
 +
</th>
 +
<td valign="top">
 +
User interface "flavor" for pki-tks component<br>Provides:  pki-tks-ui
 +
</td>
 +
<td valign="top">
 +
ant
 +
</td>
 +
<td valign="top">&nbsp;</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
pki-tks
 +
</th>
 +
<td valign="top">
 +
Token Key Service for Smartcards
 +
</td>
 +
<td valign="top">
 +
ant,<br>
 +
java-devel >= 1:1.6.0,<br>
 +
jpackage-utils,<br>
 +
jss >= 4.2.6,<br>
 +
pki-common,<br>
 +
pki-util,<br>
 +
tomcatjss
 +
</td>
 +
<td valign="top">
 +
java >= 1:1.6.0,<br>
 +
pki-tks-ui,<br>
 +
pki-common,<br>
 +
pki-console,<br>
 +
pki-selinux,<br>
 +
pki-silent,<br>
 +
(post):chkconfig,<br>
 +
(preun):chkconfig,<br>
 +
(preun):initscripts,<br>
 +
(postun):initscripts
 +
</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
{flavor}-pki-ra-ui
 +
</th>
 +
<td valign="top">
 +
User interface "flavor" for ra component<br>Provides:  pki-ra-ui
 +
</td>
 +
<td valign="top">
 +
ant
 +
</td>
 +
<td valign="top">&nbsp;</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
pki-ra
 +
</th>
 +
<td valign="top">
 +
Registration Authority
 +
</td>
 +
<td valign="top">
 +
ant
 +
</td>
 +
<td valign="top">
 +
mod_nss >= 1.0.7,<br>
 +
mod_perl >= 1.99_16,<br>
 +
mozldap >= 6.0.2,<br>
 +
pki-native-tools,<br>
 +
pki-ra-ui,<br>
 +
pki-selinux,<br>
 +
pki-setup,<br>
 +
pki-silent,<br>
 +
perl-DBD-SQLite,<br>
 +
sendmail,<br>
 +
sqlite,<br>
 +
(post):chkconfig,<br>
 +
(preun):chkconfig,<br>
 +
(preun):initscripts,<br>
 +
(postun):initscripts
 +
</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
{flavor}-pki-tps-ui
 +
</th>
 +
<td valign="top">
 +
User interface "flavor" for tps component<br>Provides:  pki-tps-ui
 +
</td>
 +
<td valign="top">
 +
ant
 +
</td>
 +
<td valign="top">&nbsp;</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
pki-tps
 +
</th>
 +
<td valign="top">
 +
Token Processing System for Smartcards
 +
</td>
 +
<td valign="top">
 +
apr-devel,<br>
 +
apr-util-devel,<br>
 +
cyrus-sasl-devel,<br>
 +
httpd-devel >= 2.2.3,<br>
 +
mozldap-devel,<br>
 +
nspr-devel >= 4.6.99,<br>
 +
nss-devel >= 3.12.3.99,<br>
 +
pcre-devel,<br>
 +
svrcore-devel,<br>
 +
zlib,<br>
 +
zlib-devel
 +
</td>
 +
<td valign="top">
 +
mod_nss >= 1.0.7,<br>
 +
mod_perl,<br>
 +
mozldap,<br>
 +
pki-native-tools,<br>
 +
pki-selinux,<br>
 +
pki-setup,<br>
 +
pki-silent,<br>
 +
pki-tps-ui,<br>
 +
(post):chkconfig,<br>
 +
(preun):chkconfig,<br>
 +
(preun):initscripts,<br>
 +
(postun):initscripts
 +
</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
pki-tps-debuginfo
 +
</th>
 +
<td valign="top">
 +
'pki-tps' subpackage for debugging.
 +
</td>
 +
<td valign="top">&nbsp;</td>
 +
<td valign="top">&nbsp;</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
pki-tps-devel
 +
</th>
 +
<td valign="top">
 +
Symlinks to the {flavor} Certificate System Token Processing System library files required to link executables.
 +
</td>
 +
<td valign="top">&nbsp;</td>
 +
<td valign="top">%{name} = %{version}-%{release}</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
{flavor}-pki
 +
</th>
 +
<td valign="top">
 +
Meta package used for convenient installation of all '{flavor}-pki' services.
 +
</td>
 +
<td valign="top">&nbsp;</td>
 +
<td valign="top">
 +
{flavor}-pki-common-ui,<br>
 +
{flavor}-pki-console-ui,<br>
 +
{flavor}-pki-ca-ui,<br>
 +
{flavor}-pki-kra-ui,<br>
 +
{flavor}-pki-ocsp-ui,<br>
 +
{flavor}-pki-ra-ui,<br>
 +
{flavor}-pki-tks-ui,<br>
 +
{flavor}-pki-tps-ui,<br>
 +
pki-ca,<br>
 +
pki-kra,<br>
 +
pki-ocsp,<br>
 +
pki-ra,<br>
 +
pki-tks,<br>
 +
pki-tps,<br>
 +
esc,<br>
 +
pki-common-javadoc,<br>
 +
pki-java-tools-javadoc,<br>
 +
pki-util-javadoc
 +
</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
<strike>
 +
pki-manage
 +
</strike>
 +
</th>
 +
<td valign="top">
 +
<strike>
 +
Perl scripts intended for management of CA, DRM, OCSP, RA, TKS, and TPS subsystems
 +
</strike>
 +
 +
<table>
 +
<tr>
 +
<td valign="top">'''<font color="RED">NOTE:&nbsp;&nbsp;</font>'''</td>
 +
<td>'''<font color="RED">As of Dogtag 1.3, the 'pki-manage' RPM has been 'discontinued' on Fedora/EPEL platforms in favor of 'yum' and 'yum-utils'!</font>'''</td>
 +
</tr>
 +
</table>
 +
</td>
 +
<td valign="top">
 +
<strike>
 +
ant
 +
</strike>
 +
</td>
 +
<td valign="top">
 +
<strike>
 +
perl >= 5.8.0
 +
</strike>
 +
</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
<strike>
 +
pki-migrate
 +
</strike>
 +
</th>
 +
<td valign="top">
 +
<strike>
 +
Pre-built applications created to migrate data between various versions of Certificate System
 +
</strike>
 +
 +
<table>
 +
<tr>
 +
<td valign="top">'''<font color="RED">NOTE:&nbsp;&nbsp;</font>'''</td>
 +
<td>'''<font color="RED">As of Dogtag 1.3, the 'pki-migrate' RPM has been 'discontinued'!</font>'''</td>
 +
</tr>
 +
</table>
 +
</td>
 +
<td valign="top">
 +
<strike>
 +
ant<br>
 +
java-devel >= 1:1.6.0<br>
 +
jpackage-utils
 +
</strike>
 +
</td>
 +
<td valign="top">
 +
<strike>
 +
java >= 1:1.6.0
 +
</strike>
 +
</td>
 +
</tr>
 +
</table>
 +
 +
=== Dogtag 1.3 and Earlier ===
  
 
'''IMPORTANT:'''  For ALL of the following components, "{flavor}" equals "dogtag"!
 
'''IMPORTANT:'''  For ALL of the following components, "{flavor}" equals "dogtag"!

Revision as of 19:41, 15 July 2011

PKI Component Packages

Dogtag 9.0

The following table lists all PKI component packages with a brief description of their purpose along with their Fedora/EPEL build and runtime dependencies:

PKI Component Description Fedora/EPEL Build Dependencies Fedora/EPEL Runtime Dependencies

osutil

A Java Native Interface (JNI) library composed of operating system utilities - PKI subsystems only utilize the various Base64 and getpid() functions

ant,
java-devel >= 1:1.6.0,
jpackage-utils,
nspr-devel >= 4.6.99,
nss-devel >= 3.12.3.99,
pkgconfig

java >= 1:1.6.0,
jpackage-utils,
nss >= 3.12.3.99

osutil-debuginfo

'osutil' subpackage for debugging.

   

pki-symkey

A Java Native Interface (JNI) library composed of symmetric key functions

NOTE:   Prior to Dogtag 1.3, the 'pki-symkey' RPM was simply called 'symkey' and contained no subpackages!

ant,
java-devel >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6,
nspr-devel >= 4.6.99,
nss-devel >= 3.12.3.99,
pkgconfig

java >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6,
nss >= 3.12.3.99

pki-symkey-debuginfo

'pki-symkey' subpackage for debugging.

   

pki-native-tools

Various stand-alone PKI tools created from C, C++, Perl, bash, etc. See PKI Native Tools for more information.

cyrus-sasl-devel,
mozldap-devel,
nspr-devel >= 4.6.99,
nss-devel >= 3.12.3.99,
svrcore-devel

mozldap-tools,
nss >= 3.12.3.99,
nss-tools >= 3.12.3.99

pki-native-tools-debug

'pki-native-tools' subpackage for debugging.

   

pki-util

Low-level PKI utilities

ant,
java-devel >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6,
ldapjdk,
osutil,
xerces-j2

java >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6,
ldapjdk

pki-util-javadoc

'pki-util' Javadocs.

  %{name} = %{version}-%{release}

pki-setup

Perl scripts intended for management of CA, DRM, OCSP, RA, TKS, and TPS subsystem instances

ant

perl-Crypt-SSLeay,
policycoreutils,
%{?fc11:policycoreutils-python},
%{?fc12:policycoreutils-python}

pki-java-tools

Various PKI tools created as stand-alone Java applications. See PKI Java Tools for more information.

ant,
java-devel >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6,
osutil,
pki-util

java >= 1:1.6.0,
pki-native-tools,
pki-util

pki-java-tools-javadoc

'pki-java-tools' Javadocs.

  %{name} = %{version}-%{release}

{flavor}-pki-common-ui

User interface "flavor" for pki-common component
Provides: pki-common-ui

ant

 

pki-common

Common PKI functions shared by the CA, DRM, OCSP, and TKS subsystems

ant,
java-devel >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6,
ldapjdk,
osutil,
pki-symkey,
pki-util,
velocity,
xalan-j2

java >= 1:1.6.0,
jss >= 4.2.6,
osutil,
pki-common-ui,
pki-java-tools,
pki-setup,
pki-symkey,
tomcatjss,
%{_javadir}/ldapjdk.jar,
%{_javadir}/velocity.jar,
%{_javadir}/xalan-j2.jar,
%{_javadir}/xerces-j2.jar,
velocity

pki-common-javadoc

'pki-common' Javadocs.

  pki-common = %{version}-%{release}

{flavor}-pki-console-ui

User interface "flavor" for pki-console component
Provides: pki-console-ui

ant,
java-devel >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6,
ldapjdk

java >= 1:1.6.0,
jss >= 4.2.6,
ldapjdk

pki-console

PKI console for management of the CA, DRM, OCSP, and TKS subsystems

ant,
idm-console-framework,
java-devel >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6,
ldapjdk,
pki-util

idm-console-framework,
java >= 1:1.6.0,
jss >= 4.2.6,
ldapjdk,
pki-console-ui

pki-selinux

Selinux policies used by the PKI components.

ant,
m4,
make,
policycoreutils,
selinux-policy-devel

policycoreutils,
selinux-policy-targeted

pki-silent

Java utility used for batch configuration of CA, DRM, OCSP, TKS, RA, and TPS subsystem instances

ant,
java-devel >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6,
pki-common,
pki-util

java >= 1:1.6.0,
pki-common

{flavor}-pki-ca-ui

User interface "flavor" for pki-ca component
Provides: pki-ca-ui

ant

 

pki-ca

Certificate Authority

ant,
java-devel >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6,
pki-common,
pki-util,
tomcatjss

java >= 1:1.6.0,
pki-ca-ui,
pki-common,
pki-console,
pki-selinux,
pki-silent,
(post):chkconfig,
(preun):chkconfig,
(preun):initscripts,
(postun):initscripts

{flavor}-pki-kra-ui

User interface "flavor" for pki-kra component
Provides: pki-kra-ui

ant

 

pki-kra

Data Recovery Manager

ant,
java-devel >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6,
pki-common,
pki-util,
tomcatjss

java >= 1:1.6.0,
pki-common,
pki-console,
pki-kra-ui,
pki-selinux,
pki-silent,
(post):chkconfig,
(preun):chkconfig,
(preun):initscripts,
(postun):initscripts

{flavor}-pki-ocsp-ui

User interface "flavor" for pki-ocsp component
Provides: pki-ocsp-ui

ant

 

pki-ocsp

Online Certificate Status Protocol Manager

ant,
java-devel >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6,
pki-common,
pki-util,
tomcatjss

java >= 1:1.6.0,
pki-common,
pki-console,
pki-ocsp-ui,
pki-selinux,
pki-silent,
(post):chkconfig,
(preun):chkconfig,
(preun):initscripts,
(postun):initscripts

{flavor}-pki-tks-ui

User interface "flavor" for pki-tks component
Provides: pki-tks-ui

ant

 

pki-tks

Token Key Service for Smartcards

ant,
java-devel >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6,
pki-common,
pki-util,
tomcatjss

java >= 1:1.6.0,
pki-tks-ui,
pki-common,
pki-console,
pki-selinux,
pki-silent,
(post):chkconfig,
(preun):chkconfig,
(preun):initscripts,
(postun):initscripts

{flavor}-pki-ra-ui

User interface "flavor" for ra component
Provides: pki-ra-ui

ant

 

pki-ra

Registration Authority

ant

mod_nss >= 1.0.7,
mod_perl >= 1.99_16,
mozldap >= 6.0.2,
pki-native-tools,
pki-ra-ui,
pki-selinux,
pki-setup,
pki-silent,
perl-DBD-SQLite,
sendmail,
sqlite,
(post):chkconfig,
(preun):chkconfig,
(preun):initscripts,
(postun):initscripts

{flavor}-pki-tps-ui

User interface "flavor" for tps component
Provides: pki-tps-ui

ant

 

pki-tps

Token Processing System for Smartcards

apr-devel,
apr-util-devel,
cyrus-sasl-devel,
httpd-devel >= 2.2.3,
mozldap-devel,
nspr-devel >= 4.6.99,
nss-devel >= 3.12.3.99,
pcre-devel,
svrcore-devel,
zlib,
zlib-devel

mod_nss >= 1.0.7,
mod_perl,
mozldap,
pki-native-tools,
pki-selinux,
pki-setup,
pki-silent,
pki-tps-ui,
(post):chkconfig,
(preun):chkconfig,
(preun):initscripts,
(postun):initscripts

pki-tps-debuginfo

'pki-tps' subpackage for debugging.

   

pki-tps-devel

Symlinks to the {flavor} Certificate System Token Processing System library files required to link executables.

  %{name} = %{version}-%{release}

{flavor}-pki

Meta package used for convenient installation of all '{flavor}-pki' services.

 

{flavor}-pki-common-ui,
{flavor}-pki-console-ui,
{flavor}-pki-ca-ui,
{flavor}-pki-kra-ui,
{flavor}-pki-ocsp-ui,
{flavor}-pki-ra-ui,
{flavor}-pki-tks-ui,
{flavor}-pki-tps-ui,
pki-ca,
pki-kra,
pki-ocsp,
pki-ra,
pki-tks,
pki-tps,
esc,
pki-common-javadoc,
pki-java-tools-javadoc,
pki-util-javadoc

pki-manage

Perl scripts intended for management of CA, DRM, OCSP, RA, TKS, and TPS subsystems

NOTE:   As of Dogtag 1.3, the 'pki-manage' RPM has been 'discontinued' on Fedora/EPEL platforms in favor of 'yum' and 'yum-utils'!

ant

perl >= 5.8.0

pki-migrate

Pre-built applications created to migrate data between various versions of Certificate System

NOTE:   As of Dogtag 1.3, the 'pki-migrate' RPM has been 'discontinued'!

ant
java-devel >= 1:1.6.0
jpackage-utils

java >= 1:1.6.0

Dogtag 1.3 and Earlier

IMPORTANT: For ALL of the following components, "{flavor}" equals "dogtag"!

The following table lists all PKI component packages with a brief description of their purpose along with their Fedora/EPEL build and runtime dependencies:

PKI Component Description Fedora/EPEL Build Dependencies Fedora/EPEL Runtime Dependencies

osutil

A Java Native Interface (JNI) library composed of operating system utilities - PKI subsystems only utilize the various Base64 and getpid() functions

ant,
java-devel >= 1:1.6.0,
jpackage-utils,
nspr-devel >= 4.6.99,
nss-devel >= 3.12.3.99,
pkgconfig

java >= 1:1.6.0,
jpackage-utils,
nss >= 3.12.3.99

osutil-debuginfo

'osutil' subpackage for debugging.

   

pki-symkey

A Java Native Interface (JNI) library composed of symmetric key functions

NOTE:   Prior to Dogtag 1.3, the 'pki-symkey' RPM was simply called 'symkey' and contained no subpackages!

ant,
java-devel >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6,
nspr-devel >= 4.6.99,
nss-devel >= 3.12.3.99,
pkgconfig

java >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6,
nss >= 3.12.3.99

pki-symkey-debuginfo

'pki-symkey' subpackage for debugging.

   

pki-native-tools

Various stand-alone PKI tools created from C, C++, Perl, bash, etc. See PKI Native Tools for more information.

cyrus-sasl-devel,
mozldap-devel,
nspr-devel >= 4.6.99,
nss-devel >= 3.12.3.99,
svrcore-devel

mozldap-tools,
nss >= 3.12.3.99,
nss-tools >= 3.12.3.99

pki-native-tools-debug

'pki-native-tools' subpackage for debugging.

   

pki-util

Low-level PKI utilities

ant,
java-devel >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6,
ldapjdk,
osutil,
xerces-j2

java >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6,
ldapjdk

pki-util-javadoc

'pki-util' Javadocs.

  %{name} = %{version}-%{release}

pki-setup

Perl scripts intended for management of CA, DRM, OCSP, RA, TKS, and TPS subsystem instances

ant

perl-Crypt-SSLeay,
policycoreutils,
%{?fc11:policycoreutils-python},
%{?fc12:policycoreutils-python}

pki-java-tools

Various PKI tools created as stand-alone Java applications. See PKI Java Tools for more information.

ant,
java-devel >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6,
osutil,
pki-util

java >= 1:1.6.0,
pki-native-tools,
pki-util

pki-java-tools-javadoc

'pki-java-tools' Javadocs.

  %{name} = %{version}-%{release}

{flavor}-pki-common-ui

User interface "flavor" for pki-common component
Provides: pki-common-ui

ant

 

pki-common

Common PKI functions shared by the CA, DRM, OCSP, and TKS subsystems

ant,
java-devel >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6,
ldapjdk,
osutil,
pki-symkey,
pki-util,
velocity,
xalan-j2

java >= 1:1.6.0,
jss >= 4.2.6,
osutil,
pki-common-ui,
pki-java-tools,
pki-setup,
pki-symkey,
tomcatjss,
%{_javadir}/ldapjdk.jar,
%{_javadir}/velocity.jar,
%{_javadir}/xalan-j2.jar,
%{_javadir}/xerces-j2.jar,
velocity

pki-common-javadoc

'pki-common' Javadocs.

  pki-common = %{version}-%{release}

{flavor}-pki-console-ui

User interface "flavor" for pki-console component
Provides: pki-console-ui

ant,
java-devel >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6,
ldapjdk

java >= 1:1.6.0,
jss >= 4.2.6,
ldapjdk

pki-console

PKI console for management of the CA, DRM, OCSP, and TKS subsystems

ant,
idm-console-framework,
java-devel >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6,
ldapjdk,
pki-util

idm-console-framework,
java >= 1:1.6.0,
jss >= 4.2.6,
ldapjdk,
pki-console-ui

pki-selinux

Selinux policies used by the PKI components.

ant,
m4,
make,
policycoreutils,
selinux-policy-devel

policycoreutils,
selinux-policy-targeted

pki-silent

Java utility used for batch configuration of CA, DRM, OCSP, TKS, RA, and TPS subsystem instances

ant,
java-devel >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6,
pki-common,
pki-util

java >= 1:1.6.0,
pki-common

{flavor}-pki-ca-ui

User interface "flavor" for pki-ca component
Provides: pki-ca-ui

ant

 

pki-ca

Certificate Authority

ant,
java-devel >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6,
pki-common,
pki-util,
tomcatjss

java >= 1:1.6.0,
pki-ca-ui,
pki-common,
pki-console,
pki-selinux,
pki-silent,
(post):chkconfig,
(preun):chkconfig,
(preun):initscripts,
(postun):initscripts

{flavor}-pki-kra-ui

User interface "flavor" for pki-kra component
Provides: pki-kra-ui

ant

 

pki-kra

Data Recovery Manager

ant,
java-devel >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6,
pki-common,
pki-util,
tomcatjss

java >= 1:1.6.0,
pki-common,
pki-console,
pki-kra-ui,
pki-selinux,
pki-silent,
(post):chkconfig,
(preun):chkconfig,
(preun):initscripts,
(postun):initscripts

{flavor}-pki-ocsp-ui

User interface "flavor" for pki-ocsp component
Provides: pki-ocsp-ui

ant

 

pki-ocsp

Online Certificate Status Protocol Manager

ant,
java-devel >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6,
pki-common,
pki-util,
tomcatjss

java >= 1:1.6.0,
pki-common,
pki-console,
pki-ocsp-ui,
pki-selinux,
pki-silent,
(post):chkconfig,
(preun):chkconfig,
(preun):initscripts,
(postun):initscripts

{flavor}-pki-tks-ui

User interface "flavor" for pki-tks component
Provides: pki-tks-ui

ant

 

pki-tks

Token Key Service for Smartcards

ant,
java-devel >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6,
pki-common,
pki-util,
tomcatjss

java >= 1:1.6.0,
pki-tks-ui,
pki-common,
pki-console,
pki-selinux,
pki-silent,
(post):chkconfig,
(preun):chkconfig,
(preun):initscripts,
(postun):initscripts

{flavor}-pki-ra-ui

User interface "flavor" for ra component
Provides: pki-ra-ui

ant

 

pki-ra

Registration Authority

ant

mod_nss >= 1.0.7,
mod_perl >= 1.99_16,
mozldap >= 6.0.2,
pki-native-tools,
pki-ra-ui,
pki-selinux,
pki-setup,
pki-silent,
perl-DBD-SQLite,
sendmail,
sqlite,
(post):chkconfig,
(preun):chkconfig,
(preun):initscripts,
(postun):initscripts

{flavor}-pki-tps-ui

User interface "flavor" for tps component
Provides: pki-tps-ui

ant

 

pki-tps

Token Processing System for Smartcards

apr-devel,
apr-util-devel,
cyrus-sasl-devel,
httpd-devel >= 2.2.3,
mozldap-devel,
nspr-devel >= 4.6.99,
nss-devel >= 3.12.3.99,
pcre-devel,
svrcore-devel,
zlib,
zlib-devel

mod_nss >= 1.0.7,
mod_perl,
mozldap,
pki-native-tools,
pki-selinux,
pki-setup,
pki-silent,
pki-tps-ui,
(post):chkconfig,
(preun):chkconfig,
(preun):initscripts,
(postun):initscripts

pki-tps-debuginfo

'pki-tps' subpackage for debugging.

   

pki-tps-devel

Symlinks to the {flavor} Certificate System Token Processing System library files required to link executables.

  %{name} = %{version}-%{release}

{flavor}-pki

Meta package used for convenient installation of all '{flavor}-pki' services.

 

{flavor}-pki-common-ui,
{flavor}-pki-console-ui,
{flavor}-pki-ca-ui,
{flavor}-pki-kra-ui,
{flavor}-pki-ocsp-ui,
{flavor}-pki-ra-ui,
{flavor}-pki-tks-ui,
{flavor}-pki-tps-ui,
pki-ca,
pki-kra,
pki-ocsp,
pki-ra,
pki-tks,
pki-tps,
esc,
pki-common-javadoc,
pki-java-tools-javadoc,
pki-util-javadoc

pki-manage

Perl scripts intended for management of CA, DRM, OCSP, RA, TKS, and TPS subsystems

NOTE:   As of Dogtag 1.3, the 'pki-manage' RPM has been 'discontinued' on Fedora/EPEL platforms in favor of 'yum' and 'yum-utils'!

ant

perl >= 5.8.0

pki-migrate

Pre-built applications created to migrate data between various versions of Certificate System

NOTE:   As of Dogtag 1.3, the 'pki-migrate' RPM has been 'discontinued'!

ant
java-devel >= 1:1.6.0
jpackage-utils

java >= 1:1.6.0