Difference between revisions of "PKI Packages"

From Dogtag
Jump to: navigation, search
(PKI Component Packages)
m
 
(86 intermediate revisions by 3 users not shown)
Line 1: Line 1:
== PKI Component Packages ==
+
= PKI Component Packages =
 +
 
 +
== Dogtag 9.0 ==
 +
 
 +
The following table lists all PKI component packages with a brief description of their purpose along with their Fedora build and runtime dependencies:
 +
 
 +
<table border=1>
 +
<tr>
 +
<th width="20%" bgcolor="#5252bf"><b><font color="white">PKI Component</font></b></th>
 +
<th width="40%" bgcolor="#5252bf"><b><font color="white">Description</font></b></th>
 +
<th width="20%" bgcolor="#5252bf"><b><font color="white">Fedora Build Dependencies</font></b></th>
 +
<th width="20%" bgcolor="#5252bf"><b><font color="white">Fedora Runtime Dependencies</font></b></th>
 +
</tr>
 +
<tr>
 +
<th bgcolor="darkgrey" colspan=4>'dogtag-pki-theme' (svn+ssh://svn.fedorahosted.org/svn/pki/trunk/pki)</th>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
dogtag-pki-common-theme
 +
</th>
 +
<td valign="top">
 +
User interface "flavor" for pki-common component:<br>
 +
<ul>
 +
<table>
 +
<tr>
 +
<td>Conflicts:&nbsp;&nbsp;</td>
 +
<td>redhat-pki-common-theme</td>
 +
</tr>
 +
<tr>
 +
<td>Conflicts:&nbsp;&nbsp;</td>
 +
<td> redhat-pki-common-ui</td>
 +
</tr>
 +
<tr>
 +
<td>Obsoletes:&nbsp;&nbsp;</td>
 +
<td>ipa-pki-common-theme <= 9999</td>
 +
</tr>
 +
<tr>
 +
<td>Provides:&nbsp;&nbsp;</td>
 +
<td>ipa-pki-common-theme = %{version}-%{release}</td>
 +
</tr>
 +
<tr>
 +
<td>Obsoletes:&nbsp;&nbsp;</td>
 +
<td>dogtag-pki-common-ui <= 9</td>
 +
</tr>
 +
<tr>
 +
<td>Provides:&nbsp;&nbsp;</td>
 +
<td>pki-common-theme = %{version}-%{release}</td>
 +
</tr>
 +
<tr>
 +
<td>Provides:&nbsp;&nbsp;</td>
 +
<td>pki-common-ui = %{version}-%{release}</td>
 +
</tr>
 +
</table>
 +
</ul>
 +
</td>
 +
<td valign="top">
 +
cmake,<br>
 +
java-devel > = 1:1.6.0,<br>
 +
jpackage-utils
 +
</td>
 +
<td valign="top">&nbsp;</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
dogtag-pki-ca-theme
 +
</th>
 +
<td valign="top">
 +
User interface "flavor" for pki-ca component:<br>
 +
<ul>
 +
<table>
 +
<tr>
 +
<td>Conflicts:&nbsp;&nbsp;</td>
 +
<td>redhat-pki-ca-theme</td>
 +
</tr>
 +
<tr>
 +
<td>Conflicts:&nbsp;&nbsp;</td>
 +
<td> redhat-pki-ca-ui</td>
 +
</tr>
 +
<tr>
 +
<td>Obsoletes:&nbsp;&nbsp;</td>
 +
<td>ipa-pki-ca-theme <= 9999</td>
 +
<tr>
 +
</tr>
 +
<td>Provides:&nbsp;&nbsp;</td>
 +
<td>ipa-pki-ca-theme = %{version}-%{release}</td>
 +
</tr>
 +
<tr>
 +
<td>Obsoletes:&nbsp;&nbsp;</td>
 +
<td>dogtag-pki-ca-ui <= 9</td>
 +
</tr>
 +
<tr>
 +
<td>Provides:&nbsp;&nbsp;</td>
 +
<td>pki-ca-theme = %{version}-%{release}</td>
 +
</tr>
 +
<tr>
 +
<td>Provides:&nbsp;&nbsp;</td>
 +
<td>pki-ca-ui = %{version}-%{release}</td>
 +
</tr>
 +
</table>
 +
</ul>
 +
</td>
 +
<td valign="top">
 +
cmake,<br>
 +
java-devel > = 1:1.6.0,<br>
 +
jpackage-utils
 +
</td>
 +
<td valign="top">dogtag-pki-common-theme = %{version}-%{release}</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
dogtag-pki-kra-theme
 +
</th>
 +
<td valign="top">
 +
User interface "flavor" for pki-kra component:<br>
 +
<ul>
 +
<table>
 +
<tr>
 +
<td>Conflicts:&nbsp;&nbsp;</td>
 +
<td>redhat-pki-kra-theme</td>
 +
</tr>
 +
<tr>
 +
<td>Conflicts:&nbsp;&nbsp;</td>
 +
<td> redhat-pki-kra-ui</td>
 +
</tr>
 +
<tr>
 +
<td>Obsoletes:&nbsp;&nbsp;</td>
 +
<td>ipa-pki-kra-theme <= 9999</td>
 +
</tr>
 +
<tr>
 +
<td>Provides:&nbsp;&nbsp;</td>
 +
<td>ipa-pki-kra-theme = %{version}-%{release}</td>
 +
</tr>
 +
<tr>
 +
<td>Obsoletes:&nbsp;&nbsp;</td>
 +
<td>dogtag-pki-kra-ui <= 9</td>
 +
</tr>
 +
<tr>
 +
<td>Provides:&nbsp;&nbsp;</td>
 +
<td>pki-kra-theme = %{version}-%{release}</td>
 +
</tr>
 +
<tr>
 +
<td>Provides:&nbsp;&nbsp;</td>
 +
<td>pki-kra-ui = %{version}-%{release}</td>
 +
</tr>
 +
</table>
 +
</ul>
 +
</td>
 +
<td valign="top">
 +
cmake,<br>
 +
java-devel > = 1:1.6.0,<br>
 +
jpackage-utils
 +
</td>
 +
<td valign="top">dogtag-pki-common-theme = %{version}-%{release}</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
dogtag-pki-ocsp-theme
 +
</th>
 +
<td valign="top">
 +
User interface "flavor" for pki-ocsp component:<br>
 +
<ul>
 +
<table>
 +
<tr>
 +
<td>Conflicts:&nbsp;&nbsp;</td>
 +
<td>redhat-pki-ocsp-theme</td>
 +
</tr>
 +
<tr>
 +
<td>Conflicts:&nbsp;&nbsp;</td>
 +
<td> redhat-pki-ocsp-ui</td>
 +
</tr>
 +
<tr>
 +
<td>Obsoletes:&nbsp;&nbsp;</td>
 +
<td>ipa-pki-ocsp-theme <= 9999</td>
 +
</tr>
 +
<tr>
 +
<td>Provides:&nbsp;&nbsp;</td>
 +
<td>ipa-pki-ocsp-theme = %{version}-%{release}</td>
 +
</tr>
 +
<tr>
 +
<td>Obsoletes:&nbsp;&nbsp;</td>
 +
<td>dogtag-pki-ocsp-ui <= 9</td>
 +
</tr>
 +
<tr>
 +
<td>Provides:&nbsp;&nbsp;</td>
 +
<td>pki-ocsp-theme = %{version}-%{release}</td>
 +
</tr>
 +
<tr>
 +
<td>Provides:&nbsp;&nbsp;</td>
 +
<td>pki-ocsp-ui = %{version}-%{release}</td>
 +
</tr>
 +
</table>
 +
</ul>
 +
</td>
 +
<td valign="top">
 +
cmake,<br>
 +
java-devel > = 1:1.6.0,<br>
 +
jpackage-utils
 +
</td>
 +
<td valign="top">dogtag-pki-common-theme = %{version}-%{release}</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
dogtag-pki-ra-theme
 +
</th>
 +
<td valign="top">
 +
User interface "flavor" for ra component:<br>
 +
<ul>
 +
<table>
 +
<tr>
 +
<td>Conflicts:&nbsp;&nbsp;</td>
 +
<td>redhat-pki-ra-theme</td>
 +
</tr>
 +
<tr>
 +
<td>Conflicts:&nbsp;&nbsp;</td>
 +
<td> redhat-pki-ra-ui</td>
 +
</tr>
 +
<tr>
 +
<td>Obsoletes:&nbsp;&nbsp;</td>
 +
<td>ipa-pki-ra-theme <= 9999</td>
 +
</tr>
 +
<tr>
 +
<td>Provides:&nbsp;&nbsp;</td>
 +
<td>ipa-pki-ra-theme = %{version}-%{release}</td>
 +
</tr>
 +
<tr>
 +
<td>Obsoletes:&nbsp;&nbsp;</td>
 +
<td>dogtag-pki-ra-ui <= 9</td>
 +
</tr>
 +
<tr>
 +
<td>Provides:&nbsp;&nbsp;</td>
 +
<td>pki-ra-theme = %{version}-%{release}</td>
 +
</tr>
 +
<tr>
 +
<td>Provides:&nbsp;&nbsp;</td>
 +
<td>pki-ra-ui = %{version}-%{release}</td>
 +
</tr>
 +
</table>
 +
</ul>
 +
</td>
 +
<td valign="top">
 +
cmake,<br>
 +
java-devel > = 1:1.6.0,<br>
 +
jpackage-utils
 +
</td>
 +
<td valign="top">&nbsp;</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
dogtag-pki-tks-theme
 +
</th>
 +
<td valign="top">
 +
User interface "flavor" for pki-tks component:<br>
 +
<ul>
 +
<table>
 +
<tr>
 +
<td>Conflicts:&nbsp;&nbsp;</td>
 +
<td>redhat-pki-tks-theme</td>
 +
</tr>
 +
<tr>
 +
<td>Conflicts:&nbsp;&nbsp;</td>
 +
<td> redhat-pki-tks-ui</td>
 +
</tr>
 +
<tr>
 +
<td>Obsoletes:&nbsp;&nbsp;</td>
 +
<td>ipa-pki-tks-theme <= 9999</td>
 +
</tr>
 +
<tr>
 +
<td>Provides:&nbsp;&nbsp;</td>
 +
<td>ipa-pki-tks-theme = %{version}-%{release}</td>
 +
</tr>
 +
<tr>
 +
<td>Obsoletes:&nbsp;&nbsp;</td>
 +
<td>dogtag-pki-tks-ui <= 9</td>
 +
</tr>
 +
<tr>
 +
<td>Provides:&nbsp;&nbsp;</td>
 +
<td>pki-tks-theme = %{version}-%{release}</td>
 +
</tr>
 +
<tr>
 +
<td>Provides:&nbsp;&nbsp;</td>
 +
<td>pki-tks-ui = %{version}-%{release}</td>
 +
</tr>
 +
</table>
 +
</ul>
 +
</td>
 +
<td valign="top">
 +
cmake,<br>
 +
java-devel > = 1:1.6.0,<br>
 +
jpackage-utils
 +
</td>
 +
<td valign="top">dogtag-pki-common-theme = %{version}-%{release}</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
dogtag-pki-tps-theme
 +
</th>
 +
<td valign="top">
 +
User interface "flavor" for pki-tps component:<br>
 +
<ul>
 +
<table>
 +
<tr>
 +
<td>Conflicts:&nbsp;&nbsp;</td>
 +
<td>redhat-pki-tps-theme</td>
 +
</tr>
 +
<tr>
 +
<td>Conflicts:&nbsp;&nbsp;</td>
 +
<td> redhat-pki-tps-ui</td>
 +
</tr>
 +
<tr>
 +
<td>Obsoletes:&nbsp;&nbsp;</td>
 +
<td>ipa-pki-tps-theme <= 9999</td>
 +
</tr>
 +
<tr>
 +
<td>Provides:&nbsp;&nbsp;</td>
 +
<td>ipa-pki-tps-theme = %{version}-%{release}</td>
 +
</tr>
 +
<tr>
 +
<td>Obsoletes:&nbsp;&nbsp;</td>
 +
<td>dogtag-pki-tps-ui <= 9</td>
 +
</tr>
 +
<tr>
 +
<td>Provides:&nbsp;&nbsp;</td>
 +
<td>pki-tps-theme = %{version}-%{release}</td>
 +
</tr>
 +
<tr>
 +
<td>Provides:&nbsp;&nbsp;</td>
 +
<td>pki-tps-ui = %{version}-%{release}</td>
 +
</tr>
 +
</table>
 +
</ul>
 +
</td>
 +
<td valign="top">
 +
cmake,<br>
 +
java-devel > = 1:1.6.0,<br>
 +
jpackage-utils
 +
</td>
 +
<td valign="top">&nbsp;</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
dogtag-pki-console-theme
 +
</th>
 +
<td valign="top">
 +
User interface "flavor" for pki-console component:<br>
 +
<ul>
 +
<table>
 +
<tr>
 +
<td>Conflicts:&nbsp;&nbsp;</td>
 +
<td>redhat-pki-console-theme</td>
 +
</tr>
 +
<tr>
 +
<td>Conflicts:&nbsp;&nbsp;</td>
 +
<td> redhat-pki-console-ui</td>
 +
</tr>
 +
<tr>
 +
<td>Obsoletes:&nbsp;&nbsp;</td>
 +
<td>ipa-pki-console-theme <= 9999</td>
 +
</tr>
 +
<tr>
 +
<td>Provides:&nbsp;&nbsp;</td>
 +
<td>ipa-pki-console-theme = %{version}-%{release}</td>
 +
</tr>
 +
<tr>
 +
<td>Obsoletes:&nbsp;&nbsp;</td>
 +
<td>dogtag-pki-console-ui <= 9</td>
 +
</tr>
 +
<tr>
 +
<td>Provides:&nbsp;&nbsp;</td>
 +
<td>pki-console-theme = %{version}-%{release}</td>
 +
</tr>
 +
<tr>
 +
<td>Provides:&nbsp;&nbsp;</td>
 +
<td>pki-console-ui = %{version}-%{release}</td>
 +
</tr>
 +
</table>
 +
</ul>
 +
</td>
 +
<td valign="top">
 +
cmake,<br>
 +
java-devel > = 1:1.6.0,<br>
 +
jpackage-utils
 +
</td>
 +
<td valign="top">
 +
java >= 1:1.6.0
 +
</td>
 +
</tr>
 +
<tr>
 +
<th bgcolor="darkgrey" colspan=4>'pki-core' (svn+ssh://svn.fedorahosted.org/svn/pki/trunk/pki)</th>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
pki-setup
 +
</th>
 +
<td valign="top">
 +
Perl scripts intended for management of CA, DRM, OCSP, RA, TKS, and TPS subsystem instances
 +
</td>
 +
<td valign="top">
 +
cmake,<br>
 +
java-devel >= 1:1.6.0,<br>
 +
jpackage-utils,<br>
 +
jss >= 4.2.6-17,<br>
 +
ldapjdk,<br>
 +
nspr-devel,<br>
 +
nss-devel,<br>
 +
openldap-devel,<br>
 +
osutil,<br>
 +
pkgconfig,<br>
 +
policycoreutils,<br>
 +
selinux-policy-devel,<br>
 +
tomcatjss >= 6.0.0,<br>
 +
velocity,<br>
 +
xalan-j2,<br>
 +
xerces-j2
 +
</td>
 +
<td valign="top">
 +
perl-Crypt-SSLeay,<br>
 +
policycoreutils,<br>
 +
openldap-clients
 +
</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
pki-symkey<br>
 +
</th>
 +
<td valign="top">
 +
A Java Native Interface (JNI) library composed of symmetric key functions
 +
</td>
 +
<td valign="top">
 +
cmake,<br>
 +
java-devel >= 1:1.6.0,<br>
 +
jpackage-utils,<br>
 +
jss >= 4.2.6-17,<br>
 +
ldapjdk,<br>
 +
nspr-devel,<br>
 +
nss-devel,<br>
 +
openldap-devel,<br>
 +
osutil,<br>
 +
pkgconfig,<br>
 +
policycoreutils,<br>
 +
selinux-policy-devel,<br>
 +
tomcatjss >= 6.0.0,<br>
 +
velocity,<br>
 +
xalan-j2,<br>
 +
xerces-j2
 +
</td>
 +
<td valign="top">
 +
java >= 1:1.6.0,<br>
 +
jpackage-utils,<br>
 +
jss >= 4.2.6-17,<br>
 +
nss
 +
</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
pki-native-tools
 +
</th>
 +
<td valign="top">
 +
Various stand-alone PKI tools created from C, C++, Perl, bash, etc.
 +
</td>
 +
<td valign="top">
 +
cmake,<br>
 +
java-devel >= 1:1.6.0,<br>
 +
jpackage-utils,<br>
 +
jss >= 4.2.6-17,<br>
 +
ldapjdk,<br>
 +
nspr-devel,<br>
 +
nss-devel,<br>
 +
openldap-devel,<br>
 +
osutil,<br>
 +
pkgconfig,<br>
 +
policycoreutils,<br>
 +
selinux-policy-devel,<br>
 +
tomcatjss >= 6.0.0,<br>
 +
velocity,<br>
 +
xalan-j2,<br>
 +
xerces-j2
 +
</td>
 +
<td valign="top">
 +
openldap-clients,<br>
 +
nss,<br>
 +
nss-tools
 +
</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
pki-util
 +
</th>
 +
<td valign="top">
 +
Low-level PKI utilities
 +
</td>
 +
<td valign="top">
 +
cmake,<br>
 +
java-devel >= 1:1.6.0,<br>
 +
jpackage-utils,<br>
 +
jss >= 4.2.6-17,<br>
 +
ldapjdk,<br>
 +
nspr-devel,<br>
 +
nss-devel,<br>
 +
openldap-devel,<br>
 +
osutil,<br>
 +
pkgconfig,<br>
 +
policycoreutils,<br>
 +
selinux-policy-devel,<br>
 +
tomcatjss >= 6.0.0,<br>
 +
velocity,<br>
 +
xalan-j2,<br>
 +
xerces-j2
 +
</td>
 +
<td valign="top">
 +
java >= 1:1.6.0,<br>
 +
jpackage-utils,<br>
 +
jss >= 4.2.6-17,<br>
 +
ldapjdk,<br>
 +
osutil
 +
</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
pki-util-javadoc
 +
</th>
 +
<td valign="top">
 +
'pki-util' Javadocs.
 +
</td>
 +
<td valign="top">&nbsp;</td>
 +
<td valign="top">pki-util = %{version}-%{release}</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
pki-java-tools
 +
</th>
 +
<td valign="top">
 +
Various PKI tools created as stand-alone Java applications.
 +
</td>
 +
<td valign="top">
 +
cmake,<br>
 +
java-devel >= 1:1.6.0,<br>
 +
jpackage-utils,<br>
 +
jss >= 4.2.6-17,<br>
 +
ldapjdk,<br>
 +
nspr-devel,<br>
 +
nss-devel,<br>
 +
openldap-devel,<br>
 +
osutil,<br>
 +
pkgconfig,<br>
 +
policycoreutils,<br>
 +
selinux-policy-devel,<br>
 +
tomcatjss >= 6.0.0,<br>
 +
velocity,<br>
 +
xalan-j2,<br>
 +
xerces-j2
 +
</td>
 +
<td valign="top">
 +
java >= 1:1.6.0,<br>
 +
pki-native-tools = %{version}-%{release},<br>
 +
pki-util = %{version}-%{release}
 +
</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
pki-java-tools-javadoc
 +
</th>
 +
<td valign="top">
 +
'pki-java-tools' Javadocs.
 +
</td>
 +
<td valign="top">&nbsp;</td>
 +
<td valign="top">pki-java-doc = %{version}-%{release}</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
pki-common
 +
</th>
 +
<td valign="top">
 +
Common PKI functions shared by the CA, DRM, OCSP, and TKS subsystems
 +
</td>
 +
<td valign="top">
 +
cmake,<br>
 +
java-devel >= 1:1.6.0,<br>
 +
jpackage-utils,<br>
 +
jss >= 4.2.6-17,<br>
 +
ldapjdk,<br>
 +
nspr-devel,<br>
 +
nss-devel,<br>
 +
openldap-devel,<br>
 +
osutil,<br>
 +
pkgconfig,<br>
 +
policycoreutils,<br>
 +
selinux-policy-devel,<br>
 +
tomcatjss >= 6.0.0,<br>
 +
velocity,<br>
 +
xalan-j2,<br>
 +
xerces-j2
 +
</td>
 +
<td valign="top">
 +
apache-commons-lang,<br>
 +
apache-commons-logging,<br>
 +
java >= 1:1.6.0,<br>
 +
jss >= 4.2.6-17,<br>
 +
pki-common-theme >= 9.0.0,<br>
 +
pki-java-tools = %{version}-%{release},<br>
 +
pki-setup = %{version}-%{release},<br>
 +
pki-symkey = %{version}-%{release},<br>
 +
tomcatjss >= 6.0.0,<br>
 +
%{_javadir}/ldapjdk.jar,<br>
 +
%{_javadir}/velocity.jar,<br>
 +
%{_javadir}/xalan-j2.jar,<br>
 +
%{_javadir}/xalan-j2-serializer.jar,<br>
 +
%{_javadir}/xerces-j2.jar,<br>
 +
%{_javadir}/xml-commons-apis.jar,<br>
 +
%{_javadir}/xml-commons-resolver.jar,<br>
 +
velocity
 +
</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
pki-common-javadoc
 +
</th>
 +
<td valign="top">
 +
'pki-common' Javadocs.
 +
</td>
 +
<td valign="top">&nbsp;</td>
 +
<td valign="top">pki-common = %{version}-%{release}</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
pki-selinux
 +
</th>
 +
<td valign="top">
 +
Selinux policies used by the PKI components.
 +
</td>
 +
<td valign="top">
 +
cmake,<br>
 +
java-devel >= 1:1.6.0,<br>
 +
jpackage-utils,<br>
 +
jss >= 4.2.6-17,<br>
 +
ldapjdk,<br>
 +
nspr-devel,<br>
 +
nss-devel,<br>
 +
openldap-devel,<br>
 +
osutil,<br>
 +
pkgconfig,<br>
 +
policycoreutils,<br>
 +
selinux-policy-devel,<br>
 +
tomcatjss >= 6.0.0,<br>
 +
velocity,<br>
 +
xalan-j2,<br>
 +
xerces-j2
 +
</td>
 +
<td valign="top">
 +
policycoreutils,<br>
 +
selinux-policy-targeted
 +
</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
pki-ca
 +
</th>
 +
<td valign="top">
 +
Certificate Authority
 +
</td>
 +
<td valign="top">
 +
cmake,<br>
 +
java-devel >= 1:1.6.0,<br>
 +
jpackage-utils,<br>
 +
jss >= 4.2.6-17,<br>
 +
ldapjdk,<br>
 +
nspr-devel,<br>
 +
nss-devel,<br>
 +
openldap-devel,<br>
 +
osutil,<br>
 +
pkgconfig,<br>
 +
policycoreutils,<br>
 +
selinux-policy-devel,<br>
 +
tomcatjss >= 6.0.0,<br>
 +
velocity,<br>
 +
xalan-j2,<br>
 +
xerces-j2
 +
</td>
 +
<td valign="top">
 +
java >= 1:1.6.0,<br>
 +
pki-ca-theme >= 9.0.0,<br>
 +
pki-common = %{version}-%{release},<br>
 +
pki-selinux = %{version}-%{release},<br>
 +
initscripts<br>
 +
<table>
 +
<tr>
 +
<td>Requires(post):&nbsp;&nbsp;</td>
 +
<td>chkconfig</td>
 +
</tr>
 +
<tr>
 +
<td>Requires(preun):&nbsp;&nbsp;</td>
 +
<td>chkconfig</td>
 +
</tr>
 +
<tr>
 +
<td>Requires(preun):&nbsp;&nbsp;</td>
 +
<td>initscripts</td>
 +
</tr>
 +
<tr>
 +
<td>Requires(postun):&nbsp;&nbsp;</td>
 +
<td>initscripts</td>
 +
</tr>
 +
</table>
 +
</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
pki-silent
 +
</th>
 +
<td valign="top">
 +
Java utility used for batch configuration of CA, DRM, OCSP, TKS, RA, and TPS subsystem instances
 +
</td>
 +
<td valign="top">
 +
cmake,<br>
 +
java-devel >= 1:1.6.0,<br>
 +
jpackage-utils,<br>
 +
jss >= 4.2.6-17,<br>
 +
ldapjdk,<br>
 +
nspr-devel,<br>
 +
nss-devel,<br>
 +
openldap-devel,<br>
 +
osutil,<br>
 +
pkgconfig,<br>
 +
policycoreutils,<br>
 +
selinux-policy-devel,<br>
 +
tomcatjss >= 6.0.0,<br>
 +
velocity,<br>
 +
xalan-j2,<br>
 +
xerces-j2
 +
</td>
 +
<td valign="top">
 +
java >= 1:1.6.0,<br>
 +
pki-common = %{version}-%{release}
 +
</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
pki-core-debuginfo
 +
</th>
 +
<td valign="top">
 +
'pki-core' subpackage for debugging containing symbols for 'pki-symkey' and 'pki-native-tools'
 +
</td>
 +
<td valign="top">&nbsp;</td>
 +
<td valign="top">&nbsp;</td>
 +
</tr>
 +
<tr>
 +
<th bgcolor="darkgrey" colspan=4>'pki-kra' (svn+ssh://svn.fedorahosted.org/svn/pki/trunk/pki)</th>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
pki-kra
 +
</th>
 +
<td valign="top">
 +
Data Recovery Manager
 +
</td>
 +
<td valign="top">
 +
cmake,<br>
 +
java-devel >= 1:1.6.0,<br>
 +
jpackage-utils,<br>
 +
jss >= 4.2.6-17,<br>
 +
nspr-devel,<br>
 +
nss-devel,<br>
 +
pki-common,<br>
 +
pki-util
 +
</td>
 +
<td valign="top">
 +
java >= 1:1.6.0,<br>
 +
pki-common,<br>
 +
pki-kra-theme,<br>
 +
pki-selinux,<br>
 +
initscripts<br>
 +
<table>
 +
<tr>
 +
<td>Requires(post):&nbsp;&nbsp;</td>
 +
<td>chkconfig</td>
 +
</tr>
 +
<tr>
 +
<td>Requires(preun):&nbsp;&nbsp;</td>
 +
<td>chkconfig</td>
 +
</tr>
 +
<tr>
 +
<td>Requires(preun):&nbsp;&nbsp;</td>
 +
<td>initscripts</td>
 +
</tr>
 +
<tr>
 +
<td>Requires(postun):&nbsp;&nbsp;</td>
 +
<td>initscripts</td>
 +
</tr>
 +
</table>
 +
</td>
 +
</tr>
 +
<tr>
 +
<th bgcolor="darkgrey" colspan=4>'pki-ocsp' (svn+ssh://svn.fedorahosted.org/svn/pki/trunk/pki)</th>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
pki-ocsp
 +
</th>
 +
<td valign="top">
 +
Online Certificate Status Protocol Manager
 +
</td>
 +
<td valign="top">
 +
cmake,<br>
 +
java-devel >= 1:1.6.0,<br>
 +
jpackage-utils,<br>
 +
jss >= 4.2.6-17,<br>
 +
nspr-devel,<br>
 +
nss-devel,<br>
 +
pki-common,<br>
 +
pki-util
 +
</td>
 +
<td valign="top">
 +
java >= 1:1.6.0,<br>
 +
pki-common,<br>
 +
pki-ocsp-theme,<br>
 +
pki-selinux,<br>
 +
initscripts<br>
 +
<table>
 +
<tr>
 +
<td>Requires(post):&nbsp;&nbsp;</td>
 +
<td>chkconfig</td>
 +
</tr>
 +
<tr>
 +
<td>Requires(preun):&nbsp;&nbsp;</td>
 +
<td>chkconfig</td>
 +
</tr>
 +
<tr>
 +
<td>Requires(preun):&nbsp;&nbsp;</td>
 +
<td>initscripts</td>
 +
</tr>
 +
<tr>
 +
<td>Requires(postun):&nbsp;&nbsp;</td>
 +
<td>initscripts</td>
 +
</tr>
 +
</table>
 +
</td>
 +
</tr>
 +
<tr>
 +
<th bgcolor="darkgrey" colspan=4>'pki-ra' (svn+ssh://svn.fedorahosted.org/svn/pki/trunk/pki)</th>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
pki-ra
 +
</th>
 +
<td valign="top">
 +
Registration Authority
 +
</td>
 +
<td valign="top">
 +
cmake,<br>
 +
nspr-devel,<br>
 +
nss-devel
 +
</td>
 +
<td valign="top">
 +
mod_nss >= 1.0.8,<br>
 +
mod_perl >= 1.99_16,<br>
 +
mod_revocator >= 1.0.3,<br>
 +
pki-native-tools,<br>
 +
pki-ra-theme,<br>
 +
pki-selinux,<br>
 +
pki-setup,<br>
 +
perl-DBD-SQLite,<br>
 +
sqlite,<br>
 +
/usr/sbin/sendmail,<br>
 +
initscripts<br>
 +
<table>
 +
<tr>
 +
<td>Requires(post):&nbsp;&nbsp;</td>
 +
<td>chkconfig</td>
 +
</tr>
 +
<tr>
 +
<td>Requires(preun):&nbsp;&nbsp;</td>
 +
<td>chkconfig</td>
 +
</tr>
 +
<tr>
 +
<td>Requires(preun):&nbsp;&nbsp;</td>
 +
<td>initscripts</td>
 +
</tr>
 +
<tr>
 +
<td>Requires(postun):&nbsp;&nbsp;</td>
 +
<td>initscripts</td>
 +
</tr>
 +
</table>
 +
</td>
 +
</tr>
 +
<tr>
 +
<th bgcolor="darkgrey" colspan=4>'pki-tks' (svn+ssh://svn.fedorahosted.org/svn/pki/trunk/pki)</th>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
pki-tks
 +
</th>
 +
<td valign="top">
 +
Token Key Service for Smartcards
 +
</td>
 +
<td valign="top">
 +
cmake,<br>
 +
java-devel >= 1:1.6.0,<br>
 +
jpackage-utils,<br>
 +
jss >= 4.2.6-17,<br>
 +
nspr-devel,<br>
 +
nss-devel,<br>
 +
pki-common,<br>
 +
pki-util
 +
</td>
 +
<td valign="top">
 +
java >= 1:1.6.0,<br>
 +
pki-common,<br>
 +
pki-selinux,<br>
 +
pki-tks-theme,<br>
 +
initscripts<br>
 +
<table>
 +
<tr>
 +
<td>Requires(post):&nbsp;&nbsp;</td>
 +
<td>chkconfig</td>
 +
</tr>
 +
<tr>
 +
<td>Requires(preun):&nbsp;&nbsp;</td>
 +
<td>chkconfig</td>
 +
</tr>
 +
<tr>
 +
<td>Requires(preun):&nbsp;&nbsp;</td>
 +
<td>initscripts</td>
 +
</tr>
 +
<tr>
 +
<td>Requires(postun):&nbsp;&nbsp;</td>
 +
<td>initscripts</td>
 +
</tr>
 +
</table>
 +
</td>
 +
</tr>
 +
<tr>
 +
<th bgcolor="darkgrey" colspan=4>'pki-tps' (svn+ssh://svn.fedorahosted.org/svn/pki/trunk/pki)</th>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
pki-tps
 +
</th>
 +
<td valign="top">
 +
Token Processing System for Smartcards
 +
</td>
 +
<td valign="top">
 +
cmake,<br>
 +
apr-devel,<br>
 +
apr-util-devel,<br>
 +
cyrus-sasl-devel,<br>
 +
httpd-devel,<br>
 +
openldap-devel,<br>
 +
nspr-devel,<br>
 +
nss-devel,<br>
 +
pcre-devel,<br>
 +
svrcore-devel,<br>
 +
zlib,<br>
 +
zlib-devel
 +
</td>
 +
<td valign="top">
 +
mod_nss,<br>
 +
mod_perl,<br>
 +
mod_revocator,<br>
 +
openldap-clients,<br>
 +
perl-Mozilla-LDAP,<br>
 +
pki-native-tools,<br>
 +
pki-selinux,<br>
 +
pki-setup,<br>
 +
pki-tps-theme,<br>
 +
initscripts<br>
 +
<table>
 +
<tr>
 +
<td>Requires(post):&nbsp;&nbsp;</td>
 +
<td>chkconfig</td>
 +
</tr>
 +
<tr>
 +
<td>Requires(preun):&nbsp;&nbsp;</td>
 +
<td>chkconfig</td>
 +
</tr>
 +
<tr>
 +
<td>Requires(preun):&nbsp;&nbsp;</td>
 +
<td>initscripts</td>
 +
</tr>
 +
<tr>
 +
<td>Requires(postun):&nbsp;&nbsp;</td>
 +
<td>initscripts</td>
 +
</tr>
 +
</table>
 +
</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
pki-tps-debuginfo
 +
</th>
 +
<td valign="top">
 +
'pki-tps' subpackage for debugging.
 +
</td>
 +
<td valign="top">&nbsp;</td>
 +
<td valign="top">&nbsp;</td>
 +
</tr>
 +
<tr>
 +
<th bgcolor="darkgrey" colspan=4>'pki-console' (svn+ssh://svn.fedorahosted.org/svn/pki/trunk/pki)</th>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
pki-console
 +
</th>
 +
<td valign="top">
 +
PKI console for management of the CA, DRM, OCSP, and TKS subsystems
 +
</td>
 +
<td valign="top">
 +
cmake,<br>
 +
idm-console-framework,<br>
 +
java-devel >= 1:1.6.0,<br>
 +
jpackage-utils,<br>
 +
jss >= 4.2.6-17,<br>
 +
ldapjdk,<br>
 +
nspr-devel,<br>
 +
nss-devel,<br>
 +
pki-util
 +
</td>
 +
<td valign="top">
 +
idm-console-framework,<br>
 +
java >= 1:1.6.0,<br>
 +
jss >= 4.2.6-17,<br>
 +
ldapjdk,<br>
 +
pki-console-theme
 +
</td>
 +
</tr>
 +
<tr>
 +
<th bgcolor="darkgrey" colspan=4>'dogtag-pki' (svn+ssh://svn.fedorahosted.org/svn/pki/trunk/pki)</th>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
dogtag-pki
 +
</th>
 +
<td valign="top">
 +
Meta package used for convenient installation of all 'dogtag-pki' "flavored" services:<br>
 +
<ul>
 +
<table>
 +
<tr>
 +
<td>Obsoletes:&nbsp;&nbsp;</td>
 +
<td>ipa-pki</td>
 +
</tr>
 +
<tr>
 +
<td>Conflicts:&nbsp;&nbsp;</td>
 +
<td> redhat-pki</td>
 +
</tr>
 +
</table>
 +
</ul>
 +
</td>
 +
<td valign="top">&nbsp;</td>
 +
<td valign="top">
 +
jss >= 4.2.6-17,<br>
 +
osutil >= 2.0.1,<br>
 +
tomcatjss >= 6.0.0,<br>
 +
jss-javadoc >= 4.2.6-17,<br>
 +
dogtag-pki-ca-theme >= 9.0.0,<br>
 +
dogtag-pki-common-theme >= 9.0.0,<br>
 +
dogtag-pki-console-theme >= 9.0.0,<br>
 +
dogtag-pki-kra-theme >= 9.0.0,<br>
 +
dogtag-pki-ocsp-theme >= 9.0.0,<br>
 +
dogtag-pki-ra-theme >= 9.0.0,<br>
 +
dogtag-pki-tks-theme >= 9.0.0,<br>
 +
dogtag-pki-tps-theme >= 9.0.0,<br>
 +
pki-ca >= 9.0.0,<br>
 +
pki-common >= 9.0.0,<br>
 +
pki-java-tools >= 9.0.0,<br>
 +
pki-native-tools >= 9.0.0,<br>
 +
pki-selinux >= 9.0.0,<br>
 +
pki-setup >= 9.0.0,<br>
 +
pki-silent >= 9.0.0,<br>
 +
pki-symkey >= 9.0.0,<br>
 +
pki-util >= 9.0.0,<br>
 +
pki-common-javadoc >= 9.0.0,<br>
 +
pki-java-tools-javadoc >= 9.0.0,<br>
 +
pki-util-javadoc >= 9.0.0,<br>
 +
pki-kra >= 9.0.0,<br>
 +
pki-ocsp >= 9.0.0,<br>
 +
pki-ra >= 9.0.0,<br>
 +
pki-tks >= 9.0.0,<br>
 +
pki-tps >= 9.0.0,<br>
 +
pki-console >= 9.0.0,<br>
 +
esc >= 1.1.0
 +
</td>
 +
</tr>
 +
</table>
 +
 
 +
 
 +
 
 +
The following table lists the PKI "support" component packages which are separately managed by various members of the PKI team with a brief description of their purpose along with their Fedora build and runtime dependencies:
 +
 
 +
<table border=1>
 +
<tr>
 +
<th width="20%" bgcolor="#5252bf"><b><font color="white">PKI Support Component</font></b></th>
 +
<th width="40%" bgcolor="#5252bf"><b><font color="white">Description</font></b></th>
 +
<th width="20%" bgcolor="#5252bf"><b><font color="white">Fedora Build Dependencies</font></b></th>
 +
<th width="20%" bgcolor="#5252bf"><b><font color="white">Fedora Runtime Dependencies</font></b></th>
 +
</tr>
 +
<tr>
 +
<th bgcolor="darkgrey" colspan=4>'osutil' (ssh://git.fedorahosted.org/git/osutil.git)</th>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
osutil
 +
</th>
 +
<td valign="top">
 +
A Java Native Interface (JNI) library composed of operating system utilities - PKI subsystems only utilize the various Base64 and getpid() functions
 +
</td>
 +
<td valign="top">
 +
cmake,<br>
 +
java-devel >= 1:1.6.0,<br>
 +
jpackage-utils,<br>
 +
nspr-devel,<br>
 +
nss-devel,<br>
 +
pkgconfig
 +
</td>
 +
<td valign="top">
 +
java >= 1:1.6.0,<br>
 +
jpackage-utils,<br>
 +
nss
 +
</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
osutil-debuginfo
 +
</th>
 +
<td valign="top">
 +
'osutil' subpackage for debugging.
 +
</td>
 +
<td valign="top">&nbsp;</td>
 +
<td valign="top">&nbsp;</td>
 +
</tr>
 +
<tr>
 +
<th bgcolor="darkgrey" colspan=4>'tomcatjss' (svn+ssh://svn.fedorahosted.org/svn/tomcatjss/trunk/tomcatjss)</th>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
tomcatjss
 +
</th>
 +
<td valign="top">
 +
A Java Secure Socket Extension (JSSE) implementation using Java Security Services (JSS) for Tomcat 6.<br>
 +
<ul>
 +
<table>
 +
<tr>
 +
<td>Conflicts:&nbsp;&nbsp;</td>
 +
<td>tomcat-native</td>
 +
</tr>
 +
</table>
 +
</ul>
 +
</td>
 +
<td valign="top">
 +
ant,<br>
 +
java-devel >= 1:1.6.0,<br>
 +
jpackage-utils,<br>
 +
tomcat6 >= 6.0.30-6,<br>
 +
jss >= 4.2.6-17
 +
</td>
 +
<td valign="top">
 +
java >= 1:1.6.0,<br>
 +
jpackage-utils,<br>
 +
tomcat6 >= 6.0.30-6,<br>
 +
jss >= 4.2.6-17
 +
</td>
 +
</tr>
 +
</table>
 +
 
 +
== Dogtag 1.3 and Earlier ==
  
 
'''IMPORTANT:'''  For ALL of the following components, "{flavor}" equals "dogtag"!
 
'''IMPORTANT:'''  For ALL of the following components, "{flavor}" equals "dogtag"!
  
The following table lists all PKI component packages with a brief description of their purpose along with their Fedora 8 build and runtime dependencies:
+
The following table lists all PKI component packages with a brief description of their purpose along with their Fedora/EPEL build and runtime dependencies:
  
 
<table border=1>
 
<table border=1>
Line 9: Line 1,169:
 
<th width="20%">PKI Component</th>
 
<th width="20%">PKI Component</th>
 
<th width="40%">Description</th>
 
<th width="40%">Description</th>
<th width="20%">Fedora 8 Build Dependencies</th>
+
<th width="20%">Fedora/EPEL Build Dependencies</th>
<th width="20%">Fedora 8 Runtime Dependencies</th>
+
<th width="20%">Fedora/EPEL Runtime Dependencies</th>
 
</tr>
 
</tr>
 
<tr>
 
<tr>
Line 20: Line 1,180:
 
</td>
 
</td>
 
<td valign="top">
 
<td valign="top">
ant >= 1.6.2,<br>
+
ant,<br>
bash >= 3.0,<br>
+
java-devel >= 1:1.6.0,<br>
java-devel >= 1.4.2,<br>
+
jpackage-utils,<br>
jpackage-utils >= 1.6.0,<br>
+
nspr-devel >= 4.6.99,<br>
nspr-devel >= 4.6.5,<br>
+
nss-devel >= 3.12.3.99,<br>
nss-devel >= 3.11.5,<br>
+
pkgconfig
nss-pkcs11-devel >= 3.11.5
 
 
</td>
 
</td>
 
<td valign="top">
 
<td valign="top">
jpackage-utils >= 1.6.0,<br>
+
java >= 1:1.6.0,<br>
nspr >= 4.6.5,<br>
+
jpackage-utils,<br>
nss >= 3.11.5
+
nss >= 3.12.3.99
 +
</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
osutil-debuginfo
 +
</th>
 +
<td valign="top">
 +
'osutil' subpackage for debugging.
 
</td>
 
</td>
 +
<td valign="top">&nbsp;</td>
 +
<td valign="top">&nbsp;</td>
 
</tr>
 
</tr>
 
<tr>
 
<tr>
 
<th valign="top">
 
<th valign="top">
symkey
+
pki-symkey<br>
 
</th>
 
</th>
 
<td valign="top">
 
<td valign="top">
 
A Java Native Interface (JNI) library composed of symmetric key functions
 
A Java Native Interface (JNI) library composed of symmetric key functions
 +
 +
<table>
 +
<tr>
 +
<td valign="top">'''<font color="RED">NOTE:&nbsp;&nbsp;</font>'''</td>
 +
<td>'''<font color="RED">Prior to Dogtag 1.3, the 'pki-symkey' RPM was simply called 'symkey' and contained no subpackages!</font>'''</td>
 +
</tr>
 +
</table>
 
</td>
 
</td>
 
<td valign="top">
 
<td valign="top">
ant >= 1.6.2,<br>
+
ant,<br>
bash >= 3.0,<br>
+
java-devel >= 1:1.6.0,<br>
java-devel >= 1.4.2,<br>
+
jpackage-utils,<br>
jpackage-utils >= 1.6.0,<br>
+
jss >= 4.2.6,<br>
jss >= 4.2.4,<br>
+
nspr-devel >= 4.6.99,<br>
nspr-devel >= 4.6.5,<br>
+
nss-devel >= 3.12.3.99,<br>
nss-devel >= 3.11.5,<br>
+
pkgconfig
nss-pkcs11-devel >= 3.11.5
 
 
</td>
 
</td>
 
<td valign="top">
 
<td valign="top">
jpackage-utils >= 1.6.0,<br>
+
java >= 1:1.6.0,<br>
jss >= 4.2.4,<br>
+
jpackage-utils,<br>
nspr >= 4.6.5,<br>
+
jss >= 4.2.6,<br>
nss >= 3.11.5
+
nss >= 3.12.3.99
 +
</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
pki-symkey-debuginfo
 +
</th>
 +
<td valign="top">
 +
'pki-symkey' subpackage for debugging.
 
</td>
 
</td>
 +
<td valign="top">&nbsp;</td>
 +
<td valign="top">&nbsp;</td>
 
</tr>
 
</tr>
 
<tr>
 
<tr>
 
<th valign="top">
 
<th valign="top">
pki-util
+
pki-native-tools
 
</th>
 
</th>
 
<td valign="top">
 
<td valign="top">
Low-level PKI utilities
+
Various stand-alone PKI tools created from C, C++, Perl, bash, etc.
 +
</td>
 +
<td valign="top">
 +
cyrus-sasl-devel,<br>
 +
mozldap-devel,<br>
 +
nspr-devel >= 4.6.99,<br>
 +
nss-devel >= 3.12.3.99,<br>
 +
svrcore-devel
 
</td>
 
</td>
 
<td valign="top">
 
<td valign="top">
ant >= 1.6.2,<br>
+
mozldap-tools,<br>
java-sdk >= 1.7.0,<br>
+
nss >= 3.12.3.99,<br>
jpackage-utils >= 1.6.0,<br>
+
nss-tools >= 3.12.3.99
jss >= 4.2.4,<br>
 
ldapjdk >= 4.17,<br>
 
osutil >= 1.0.0
 
 
</td>
 
</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
pki-native-tools-debug
 +
</th>
 
<td valign="top">
 
<td valign="top">
jpackage-utils >= 1.6.0,<br>
+
'pki-native-tools' subpackage for debugging.
jss >= 4.2.4,<br>
 
ldapjdk >= 4.17
 
 
</td>
 
</td>
 +
<td valign="top">&nbsp;</td>
 +
<td valign="top">&nbsp;</td>
 
</tr>
 
</tr>
 
<tr>
 
<tr>
 
<th valign="top">
 
<th valign="top">
pki-native-tools
+
pki-util
 
</th>
 
</th>
 
<td valign="top">
 
<td valign="top">
Various stand-alone PKI tools created from C, C++, Perl, bash, etc.  See [[PKI Native Tools]] for more information.
+
Low-level PKI utilities
 
</td>
 
</td>
 
<td valign="top">
 
<td valign="top">
bash >= 3.0,<br>
+
ant,<br>
cyrus-sasl-devel >= 2.1.19,<br>
+
java-devel >= 1:1.6.0,<br>
mozldap-devel >= 6.0.2,<br>
+
jpackage-utils,<br>
nspr-devel >= 4.6.5,<br>
+
jss >= 4.2.6,<br>
nss-devel >= 3.11.5,<br>
+
ldapjdk,<br>
nss-pkcs11-devel >= 3.11.5,<br>
+
osutil,<br>
svrcore-devel >= 4.0.3.01
+
xerces-j2
 
</td>
 
</td>
 
<td valign="top">
 
<td valign="top">
mozldap-tools >= 6.0.2,<br>
+
java >= 1:1.6.0,<br>
nss >= 3.11.5,<br>
+
jpackage-utils,<br>
nss-tools >= 3.11.5
+
jss >= 4.2.6,<br>
 +
ldapjdk
 
</td>
 
</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
pki-util-javadoc
 +
</th>
 +
<td valign="top">
 +
'pki-util' Javadocs.
 +
</td>
 +
<td valign="top">&nbsp;</td>
 +
<td valign="top">%{name} = %{version}-%{release}</td>
 
</tr>
 
</tr>
 
<tr>
 
<tr>
Line 109: Line 1,314:
 
</td>
 
</td>
 
<td valign="top">
 
<td valign="top">
ant >= 1.6.2
+
ant
 
</td>
 
</td>
 
<td valign="top">
 
<td valign="top">
pki-native-tools >= 1.0.0,<br>
+
perl-Crypt-SSLeay,<br>
perl >= 5.8.0
+
policycoreutils,<br>
 +
%{?fc11:policycoreutils-python},<br>
 +
%{?fc12:policycoreutils-python}
 
</td>
 
</td>
 
</tr>
 
</tr>
Line 121: Line 1,328:
 
</th>
 
</th>
 
<td valign="top">
 
<td valign="top">
Various PKI tools created as stand-alone Java applications.  See [[PKI Java Tools]] for more information.
+
Various PKI tools created as stand-alone Java applications.
 
</td>
 
</td>
 
<td valign="top">
 
<td valign="top">
ant >= 1.6.2,<br>
+
ant,<br>
pki-util >= 1.0.0,<br>
+
java-devel >= 1:1.6.0,<br>
java-devel >= 1.4.2,<br>
+
jpackage-utils,<br>
jpackage-utils >= 1.6.0,<br>
+
jss >= 4.2.6,<br>
jss >= 4.2.4
+
osutil,<br>
 +
pki-util
 
</td>
 
</td>
 
<td valign="top">
 
<td valign="top">
pki-native-tools >= 1.0.0,<br>
+
java >= 1:1.6.0,<br>
pki-util >= 1.0.0,<br>
+
pki-native-tools,<br>
java >= 1.4.2
+
pki-util
 
</td>
 
</td>
 
</tr>
 
</tr>
 
<tr>
 
<tr>
 
<th valign="top">
 
<th valign="top">
{flavor}-pki-common-ui
+
pki-java-tools-javadoc
 
</th>
 
</th>
 
<td valign="top">
 
<td valign="top">
User interface "flavor" for pki-common component
+
'pki-java-tools' Javadocs.
 
</td>
 
</td>
 +
<td valign="top">&nbsp;</td>
 +
<td valign="top">%{name} = %{version}-%{release}</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
{flavor}-pki-common-ui
 +
</th>
 
<td valign="top">
 
<td valign="top">
ant >= 1.6.2
+
User interface "flavor" for pki-common component<br>Provides:  pki-common-ui
 
</td>
 
</td>
 
<td valign="top">
 
<td valign="top">
bash >= 3.0
+
ant
 
</td>
 
</td>
 +
<td valign="top">&nbsp;</td>
 
</tr>
 
</tr>
 
<tr>
 
<tr>
Line 158: Line 1,374:
 
</td>
 
</td>
 
<td valign="top">
 
<td valign="top">
ant >= 1.6.2,<br>
+
ant,<br>
pki-util >= 1.0.0,<br>
+
java-devel >= 1:1.6.0,<br>
pki-common-ui >= 1.0.0,<br>
+
jpackage-utils,<br>
java-devel >= 1.4.2,<br>
+
jss >= 4.2.6,<br>
jpackage-utils >= 1.6.0,<br>
+
ldapjdk,<br>
jss >= 4.2.4,<br>
+
osutil,<br>
ldapjdk >= 4.17,<br>
+
pki-symkey,<br>
osutil >= 1.0.0,<br>
+
pki-util,<br>
symkey >= 1.0.0,<br>
+
velocity,<br>
velocity >= 1.4
+
xalan-j2
 
</td>
 
</td>
 
<td valign="top">
 
<td valign="top">
 +
java >= 1:1.6.0,<br>
 +
jss >= 4.2.6,<br>
 +
osutil,<br>
 
pki-common-ui,<br>
 
pki-common-ui,<br>
pki-java-tools >= 1.0.0,<br>
+
pki-java-tools,<br>
pki-setup >= 1.0.0,<br>
+
pki-setup,<br>
java >= 1.4.2,<br>
+
pki-symkey,<br>
osutil >= 1.0.0,<br>
+
tomcatjss,<br>
rhgb >= 0.14.1,<br>
+
%{_javadir}/ldapjdk.jar,<br>
symkey >= 1.0.0,<br>
+
%{_javadir}/velocity.jar,<br>
tomcatjss >= 1.1.0,<br>
+
%{_javadir}/xalan-j2.jar,<br>
velocity >= 1.4
+
%{_javadir}/xerces-j2.jar,<br>
 +
velocity
 +
</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
pki-common-javadoc
 +
</th>
 +
<td valign="top">
 +
'pki-common' Javadocs.
 +
</td>
 +
<td valign="top">&nbsp;</td>
 +
<td valign="top">pki-common = %{version}-%{release}</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
{flavor}-pki-console-ui
 +
</th>
 +
<td valign="top">
 +
User interface "flavor" for pki-console component<br>Provides:  pki-console-ui
 +
</td>
 +
<td valign="top">
 +
ant,<br>
 +
java-devel >= 1:1.6.0,<br>
 +
jpackage-utils,<br>
 +
jss >= 4.2.6,<br>
 +
ldapjdk
 +
</td>
 +
<td valign="top">
 +
java >= 1:1.6.0,<br>
 +
jss >= 4.2.6,<br>
 +
ldapjdk
 
</td>
 
</td>
 
</tr>
 
</tr>
 
<tr>
 
<tr>
 
<th valign="top">
 
<th valign="top">
{flavor}-pki-ca-ui
+
pki-console
 +
</th>
 +
<td valign="top">
 +
PKI console for management of the CA, DRM, OCSP, and TKS subsystems
 +
</td>
 +
<td valign="top">
 +
ant,<br>
 +
idm-console-framework,<br>
 +
java-devel >= 1:1.6.0,<br>
 +
jpackage-utils,<br>
 +
jss >= 4.2.6,<br>
 +
ldapjdk,<br>
 +
pki-util
 +
</td>
 +
<td valign="top">
 +
idm-console-framework,<br>
 +
java >= 1:1.6.0,<br>
 +
jss >= 4.2.6,<br>
 +
ldapjdk,<br>
 +
pki-console-ui
 +
</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
pki-selinux
 +
</th>
 +
<td valign="top">
 +
Selinux policies used by the PKI components.
 +
</td>
 +
<td valign="top">
 +
ant,<br>
 +
m4,<br>
 +
make,<br>
 +
policycoreutils,<br>
 +
selinux-policy-devel
 +
</td>
 +
<td valign="top">
 +
policycoreutils,<br>
 +
selinux-policy-targeted
 +
</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
pki-silent
 
</th>
 
</th>
 
<td valign="top">
 
<td valign="top">
User interface "flavor" for pki-ca component
+
Java utility used for batch configuration of CA, DRM, OCSP, TKS, RA, and TPS subsystem instances
 +
</td>
 +
<td valign="top">
 +
ant,<br>
 +
java-devel >= 1:1.6.0,<br>
 +
jpackage-utils,<br>
 +
jss >= 4.2.6,<br>
 +
pki-common,<br>
 +
pki-util
 +
</td>
 +
<td valign="top">
 +
java >= 1:1.6.0,<br>
 +
pki-common
 
</td>
 
</td>
 +
</tr>
 +
<tr>
 +
<th valign="top">
 +
{flavor}-pki-ca-ui
 +
</th>
 
<td valign="top">
 
<td valign="top">
ant >= 1.6.2
+
User interface "flavor" for pki-ca component<br>Provides:  pki-ca-ui
 
</td>
 
</td>
 
<td valign="top">
 
<td valign="top">
bash >= 3.0
+
ant
 
</td>
 
</td>
 +
<td valign="top">&nbsp;</td>
 
</tr>
 
</tr>
 
<tr>
 
<tr>
Line 203: Line 1,514:
 
</td>
 
</td>
 
<td valign="top">
 
<td valign="top">
ant >= 1.6.2,<br>
+
ant,<br>
pki-ca-ui >= 1.0.0,<br>
+
java-devel >= 1:1.6.0,<br>
pki-common >= 1.0.0,<br>
+
jpackage-utils,<br>
pki-util >= 1.0.0,<br>
+
jss >= 4.2.6,<br>
java-devel >= 1.4.2,<br>
+
pki-common,<br>
jpackage-utils >= 1.6.0,<br>
+
pki-util,<br>
jss >= 4.2.4
+
tomcatjss
 
</td>
 
</td>
 
<td valign="top">
 
<td valign="top">
 +
java >= 1:1.6.0,<br>
 
pki-ca-ui,<br>
 
pki-ca-ui,<br>
pki-common >= 1.0.0
+
pki-common,<br>
 +
pki-console,<br>
 +
pki-selinux,<br>
 +
pki-silent,<br>
 +
(post):chkconfig,<br>
 +
(preun):chkconfig,<br>
 +
(preun):initscripts,<br>
 +
(postun):initscripts
 
</td>
 
</td>
 
</tr>
 
</tr>
Line 221: Line 1,540:
 
</th>
 
</th>
 
<td valign="top">
 
<td valign="top">
User interface "flavor" for pki-kra component
+
User interface "flavor" for pki-kra component<br>Provides:  pki-kra-ui
 
</td>
 
</td>
 
<td valign="top">
 
<td valign="top">
ant >= 1.6.2
+
ant
</td>
 
<td valign="top">
 
bash >= 3.0
 
 
</td>
 
</td>
 +
<td valign="top">&nbsp;</td>
 
</tr>
 
</tr>
 
<tr>
 
<tr>
Line 238: Line 1,555:
 
</td>
 
</td>
 
<td valign="top">
 
<td valign="top">
ant >= 1.6.2,<br>
+
ant,<br>
pki-kra-ui >= 1.0.0,<br>
+
java-devel >= 1:1.6.0,<br>
pki-common >= 1.0.0,<br>
+
jpackage-utils,<br>
pki-util >= 1.0.0,<br>
+
jss >= 4.2.6,<br>
java-devel >= 1.4.2,<br>
+
pki-common,<br>
jpackage-utils >= 1.6.0,<br>
+
pki-util,<br>
jss >= 4.2.4
+
tomcatjss
 
</td>
 
</td>
 
<td valign="top">
 
<td valign="top">
 +
java >= 1:1.6.0,<br>
 +
pki-common,<br>
 +
pki-console,<br>
 
pki-kra-ui,<br>
 
pki-kra-ui,<br>
pki-common >= 1.0.0
+
pki-selinux,<br>
 +
pki-silent,<br>
 +
(post):chkconfig,<br>
 +
(preun):chkconfig,<br>
 +
(preun):initscripts,<br>
 +
(postun):initscripts
 
</td>
 
</td>
 
</tr>
 
</tr>
 +
 +
 +
 
<tr>
 
<tr>
 
<th valign="top">
 
<th valign="top">
Line 256: Line 1,584:
 
</th>
 
</th>
 
<td valign="top">
 
<td valign="top">
User interface "flavor" for pki-ocsp component
+
User interface "flavor" for pki-ocsp component<br>Provides:  pki-ocsp-ui
 
</td>
 
</td>
 
<td valign="top">
 
<td valign="top">
ant >= 1.6.2
+
ant
</td>
 
<td valign="top">
 
bash >= 3.0
 
 
</td>
 
</td>
 +
<td valign="top">&nbsp;</td>
 
</tr>
 
</tr>
 
<tr>
 
<tr>
Line 273: Line 1,599:
 
</td>
 
</td>
 
<td valign="top">
 
<td valign="top">
ant >= 1.6.2,<br>
+
ant,<br>
pki-ocsp-ui >= 1.0.0,<br>
+
java-devel >= 1:1.6.0,<br>
pki-common >= 1.0.0,<br>
+
jpackage-utils,<br>
pki-util >= 1.0.0,<br>
+
jss >= 4.2.6,<br>
java-devel >= 1.4.2,<br>
+
pki-common,<br>
jpackage-utils >= 1.6.0,<br>
+
pki-util,<br>
jss >= 4.2.4
+
tomcatjss
 
</td>
 
</td>
 
<td valign="top">
 
<td valign="top">
 +
java >= 1:1.6.0,<br>
 +
pki-common,<br>
 +
pki-console,<br>
 
pki-ocsp-ui,<br>
 
pki-ocsp-ui,<br>
pki-common >= 1.0.0
+
pki-selinux,<br>
 +
pki-silent,<br>
 +
(post):chkconfig,<br>
 +
(preun):chkconfig,<br>
 +
(preun):initscripts,<br>
 +
(postun):initscripts
 
</td>
 
</td>
 
</tr>
 
</tr>
Line 291: Line 1,625:
 
</th>
 
</th>
 
<td valign="top">
 
<td valign="top">
User interface "flavor" for pki-tks component
+
User interface "flavor" for pki-tks component<br>Provides:  pki-tks-ui
</td>
 
<td valign="top">
 
ant >= 1.6.2
 
 
</td>
 
</td>
 
<td valign="top">
 
<td valign="top">
bash >= 3.0
+
ant
 
</td>
 
</td>
 +
<td valign="top">&nbsp;</td>
 
</tr>
 
</tr>
 
<tr>
 
<tr>
Line 308: Line 1,640:
 
</td>
 
</td>
 
<td valign="top">
 
<td valign="top">
ant >= 1.6.2,<br>
+
ant,<br>
pki-tks-ui >= 1.0.0,<br>
+
java-devel >= 1:1.6.0,<br>
pki-common >= 1.0.0,<br>
+
jpackage-utils,<br>
pki-util >= 1.0.0,<br>
+
jss >= 4.2.6,<br>
java-devel >= 1.4.2,<br>
+
pki-common,<br>
jpackage-utils >= 1.6.0,<br>
+
pki-util,<br>
jss >= 4.2.4
+
tomcatjss
 
</td>
 
</td>
 
<td valign="top">
 
<td valign="top">
 +
java >= 1:1.6.0,<br>
 
pki-tks-ui,<br>
 
pki-tks-ui,<br>
pki-common >= 1.0.0
+
pki-common,<br>
 +
pki-console,<br>
 +
pki-selinux,<br>
 +
pki-silent,<br>
 +
(post):chkconfig,<br>
 +
(preun):chkconfig,<br>
 +
(preun):initscripts,<br>
 +
(postun):initscripts
 
</td>
 
</td>
 
</tr>
 
</tr>
Line 326: Line 1,666:
 
</th>
 
</th>
 
<td valign="top">
 
<td valign="top">
User interface "flavor" for ra component
+
User interface "flavor" for ra component<br>Provides:  pki-ra-ui
</td>
 
<td valign="top">
 
ant >= 1.6.2
 
 
</td>
 
</td>
 
<td valign="top">
 
<td valign="top">
bash >= 3.0
+
ant
 
</td>
 
</td>
 +
<td valign="top">&nbsp;</td>
 
</tr>
 
</tr>
 
<tr>
 
<tr>
Line 343: Line 1,681:
 
</td>
 
</td>
 
<td valign="top">
 
<td valign="top">
ant >= 1.6.2,<br>
+
ant
pki-ra-ui >= 1.0.0
 
 
</td>
 
</td>
 
<td valign="top">
 
<td valign="top">
pki-ra-ui,<br>
+
mod_nss >= 1.0.7,<br>
pki-setup >= 1.0.0,<br>
 
mod_nss >= 1.0.3,<br>
 
 
mod_perl >= 1.99_16,<br>
 
mod_perl >= 1.99_16,<br>
 
mozldap >= 6.0.2,<br>
 
mozldap >= 6.0.2,<br>
perl-DBD-SQLite >= 1.11,<br>
+
pki-native-tools,<br>
perl-HTML-Parser >= 3.35,<br>
+
pki-ra-ui,<br>
perl-HTML-Tagset >= 3.03,<br>
+
pki-selinux,<br>
perl-Parse-RecDescent >= 1.94,<br>
+
pki-setup,<br>
perl-URI >= 1.30,<br>
+
pki-silent,<br>
perl-XML-NamespaceSupport >= 1.08,<br>
+
perl-DBD-SQLite,<br>
perl-XML-Parser >= 2.34,<br>
+
sendmail,<br>
perl-XML-SAX >= 0.12,<br>
+
sqlite,<br>
perl-XML-Simple >= 2.14,<br>
+
(post):chkconfig,<br>
perl-libwww-perl >= 5.79,<br>
+
(preun):chkconfig,<br>
sendmail >= 8.13.1,<br>
+
(preun):initscripts,<br>
sqlite >= 3.3.3
+
(postun):initscripts
 
</td>
 
</td>
 
</tr>
 
</tr>
Line 371: Line 1,706:
 
</th>
 
</th>
 
<td valign="top">
 
<td valign="top">
User interface "flavor" for tps component
+
User interface "flavor" for tps component<br>Provides:  pki-tps-ui
</td>
 
<td valign="top">
 
ant >= 1.6.2
 
 
</td>
 
</td>
 
<td valign="top">
 
<td valign="top">
bash >= 3.0
+
ant
 
</td>
 
</td>
 +
<td valign="top">&nbsp;</td>
 
</tr>
 
</tr>
 
<tr>
 
<tr>
Line 388: Line 1,721:
 
</td>
 
</td>
 
<td valign="top">
 
<td valign="top">
apr-devel >= 0.9.4,<br>
+
apr-devel,<br>
apr-util-devel >= 0.9.4,<br>
+
apr-util-devel,<br>
pki-tps-ui >= 1.0.0,<br>
+
cyrus-sasl-devel,<br>
bash >= 3.0,<br>
+
httpd-devel >= 2.2.3,<br>
cyrus-sasl-devel >= 2.1.19,<br>
+
mozldap-devel,<br>
httpd-devel >= 2.0.52,<br>
+
nspr-devel >= 4.6.99,<br>
mozldap-devel >= 6.0.2,<br>
+
nss-devel >= 3.12.3.99,<br>
nspr-devel >= 4.6.5,<br>
+
pcre-devel,<br>
nss-devel >= 3.11.5,<br>
+
svrcore-devel,<br>
nss-pkcs11-devel >= 3.11.5,<br>
+
zlib,<br>
pcre-devel >= 6.6,<br>
+
zlib-devel
svrcore-devel >= 4.0.3.01,<br>
 
zlib >= 1.2.3
 
 
</td>
 
</td>
 
<td valign="top">
 
<td valign="top">
pki-setup >= 1.0.0,<br>
+
mod_nss >= 1.0.7,<br>
 +
mod_perl,<br>
 +
mozldap,<br>
 +
pki-native-tools,<br>
 +
pki-selinux,<br>
 +
pki-setup,<br>
 +
pki-silent,<br>
 
pki-tps-ui,<br>
 
pki-tps-ui,<br>
mod_nss >= 1.0.3,<br>
+
(post):chkconfig,<br>
mod_perl >= 1.99_16,<br>
+
(preun):chkconfig,<br>
mozldap >= 6.0.2,<br>
+
(preun):initscripts,<br>
perl-HTML-Parser >= 3.35,<br>
+
(postun):initscripts
perl-HTML-Tagset >= 3.03,<br>
 
perl-Parse-RecDescent >= 1.94,<br>
 
perl-URI >= 1.30,<br>
 
perl-XML-NamespaceSupport >= 1.08,<br>
 
perl-XML-Parser >= 2.34,<br>
 
perl-XML-SAX >= 0.12,<br>
 
perl-XML-Simple >= 2.14,<br>
 
perl-libwww-perl >= 5.79
 
 
</td>
 
</td>
 
</tr>
 
</tr>
 
<tr>
 
<tr>
 
<th valign="top">
 
<th valign="top">
pki-manage
+
pki-tps-debuginfo
 
</th>
 
</th>
 
<td valign="top">
 
<td valign="top">
Perl scripts intended for management of CA, DRM, OCSP, RA, TKS, and TPS subsystems
+
'pki-tps' subpackage for debugging.
</td>
 
<td valign="top">
 
ant >= 1.6.2
 
</td>
 
<td valign="top">
 
perl >= 5.8.0
 
 
</td>
 
</td>
 +
<td valign="top">&nbsp;</td>
 +
<td valign="top">&nbsp;</td>
 
</tr>
 
</tr>
 
<tr>
 
<tr>
 
<th valign="top">
 
<th valign="top">
{flavor}-pki-console-ui
+
pki-tps-devel
 
</th>
 
</th>
 
<td valign="top">
 
<td valign="top">
User interface "flavor" for pki-console component
+
Symlinks to the {flavor} Certificate System Token Processing System library files required to link executables.
</td>
 
<td valign="top">
 
ant >= 1.6.2,<br>
 
java-devel >= 1.4.2,<br>
 
jpackage-utils >= 1.6.0,<br>
 
jss >= 4.2.4,<br>
 
ldapjdk >= 4.17
 
</td>
 
<td valign="top">
 
jss >= 4.2.4,<br>
 
ldapjdk >= 4.17
 
 
</td>
 
</td>
 +
<td valign="top">&nbsp;</td>
 +
<td valign="top">%{name} = %{version}-%{release}</td>
 
</tr>
 
</tr>
 
<tr>
 
<tr>
 
<th valign="top">
 
<th valign="top">
pki-console
+
{flavor}-pki
 
</th>
 
</th>
 
<td valign="top">
 
<td valign="top">
PKI console for management of the CA, DRM, OCSP, and TKS subsystems
+
Meta package used for convenient installation of all '{flavor}-pki' services.
 
</td>
 
</td>
 +
<td valign="top">&nbsp;</td>
 
<td valign="top">
 
<td valign="top">
ant >= 1.6.2,<br>
+
{flavor}-pki-common-ui,<br>
pki-util >= 1.0.0,<br>
+
{flavor}-pki-console-ui,<br>
pki-console-ui >= 1.0.0,<br>
+
{flavor}-pki-ca-ui,<br>
idm-console-framework >= 1.0.3,<br>
+
{flavor}-pki-kra-ui,<br>
jpackage-utils >= 1.6.0,<br>
+
{flavor}-pki-ocsp-ui,<br>
jss >= 4.2.4,<br>
+
{flavor}-pki-ra-ui,<br>
ldapjdk >= 4.17,<br>
+
{flavor}-pki-tks-ui,<br>
java-sdk >= 1.7.0
+
{flavor}-pki-tps-ui,<br>
</td>
+
pki-ca,<br>
<td valign="top">
+
pki-kra,<br>
pki-console-ui,<br>
+
pki-ocsp,<br>
idm-console-framework >= 1.0.3,<br>
+
pki-ra,<br>
jss >= 4.2.4,<br>
+
pki-tks,<br>
ldapjdk >= 4.17
+
pki-tps,<br>
 +
esc,<br>
 +
pki-common-javadoc,<br>
 +
pki-java-tools-javadoc,<br>
 +
pki-util-javadoc
 
</td>
 
</td>
 
</tr>
 
</tr>
 
<tr>
 
<tr>
 
<th valign="top">
 
<th valign="top">
pki-silent
+
<strike>
 +
pki-manage
 +
</strike>
 
</th>
 
</th>
 
<td valign="top">
 
<td valign="top">
Java utility used for batch configuration of CA, DRM, OCSP, TKS, RA, and TPS subsystem instances
+
<strike>
 +
Perl scripts intended for management of CA, DRM, OCSP, RA, TKS, and TPS subsystems
 +
</strike>
 +
 
 +
<table>
 +
<tr>
 +
<td valign="top">'''<font color="RED">NOTE:&nbsp;&nbsp;</font>'''</td>
 +
<td>'''<font color="RED">As of Dogtag 1.3, the 'pki-manage' RPM has been 'discontinued' on Fedora/EPEL platforms in favor of 'yum' and 'yum-utils'!</font>'''</td>
 +
</tr>
 +
</table>
 
</td>
 
</td>
 
<td valign="top">
 
<td valign="top">
ant >= 1.6.2,<br>
+
<strike>
pki-common >= 1.0.0,<br>
+
ant
pki-util >= 1.0.0,<br>
+
</strike>
java-devel >= 1.4.2,<br>
 
jpackage-utils >= 1.6.0,<br>
 
jss >= 4.2.4
 
 
</td>
 
</td>
 
<td valign="top">
 
<td valign="top">
pki-common >= 1.0.0
+
<strike>
 +
perl >= 5.8.0
 +
</strike>
 
</td>
 
</td>
 
</tr>
 
</tr>
 
<tr>
 
<tr>
 
<th valign="top">
 
<th valign="top">
 +
<strike>
 
pki-migrate
 
pki-migrate
 +
</strike>
 
</th>
 
</th>
 
<td valign="top">
 
<td valign="top">
 +
<strike>
 
Pre-built applications created to migrate data between various versions of Certificate System
 
Pre-built applications created to migrate data between various versions of Certificate System
 +
</strike>
 +
 +
<table>
 +
<tr>
 +
<td valign="top">'''<font color="RED">NOTE:&nbsp;&nbsp;</font>'''</td>
 +
<td>'''<font color="RED">As of Dogtag 1.3, the 'pki-migrate' RPM has been 'discontinued'!</font>'''</td>
 +
</tr>
 +
</table>
 
</td>
 
</td>
 
<td valign="top">
 
<td valign="top">
N/A
+
<strike>
 +
ant<br>
 +
java-devel >= 1:1.6.0<br>
 +
jpackage-utils
 +
</strike>
 
</td>
 
</td>
 
<td valign="top">
 
<td valign="top">
java
+
<strike>
 +
java >= 1:1.6.0
 +
</strike>
 
</td>
 
</td>
 
</tr>
 
</tr>

Latest revision as of 02:30, 17 June 2021

PKI Component Packages

Dogtag 9.0

The following table lists all PKI component packages with a brief description of their purpose along with their Fedora build and runtime dependencies:

PKI Component Description Fedora Build Dependencies Fedora Runtime Dependencies
'dogtag-pki-theme' (svn+ssh://svn.fedorahosted.org/svn/pki/trunk/pki)

dogtag-pki-common-theme

User interface "flavor" for pki-common component:

    Conflicts:   redhat-pki-common-theme
    Conflicts:   redhat-pki-common-ui
    Obsoletes:   ipa-pki-common-theme <= 9999
    Provides:   ipa-pki-common-theme = %{version}-%{release}
    Obsoletes:   dogtag-pki-common-ui <= 9
    Provides:   pki-common-theme = %{version}-%{release}
    Provides:   pki-common-ui = %{version}-%{release}

cmake,
java-devel > = 1:1.6.0,
jpackage-utils

 

dogtag-pki-ca-theme

User interface "flavor" for pki-ca component:

    </tr>

    Conflicts:   redhat-pki-ca-theme
    Conflicts:   redhat-pki-ca-ui
    Obsoletes:   ipa-pki-ca-theme <= 9999
    Provides:   ipa-pki-ca-theme = %{version}-%{release}
    Obsoletes:   dogtag-pki-ca-ui <= 9
    Provides:   pki-ca-theme = %{version}-%{release}
    Provides:   pki-ca-ui = %{version}-%{release}

cmake,
java-devel > = 1:1.6.0,
jpackage-utils

dogtag-pki-common-theme = %{version}-%{release}

dogtag-pki-kra-theme

User interface "flavor" for pki-kra component:

    Conflicts:   redhat-pki-kra-theme
    Conflicts:   redhat-pki-kra-ui
    Obsoletes:   ipa-pki-kra-theme <= 9999
    Provides:   ipa-pki-kra-theme = %{version}-%{release}
    Obsoletes:   dogtag-pki-kra-ui <= 9
    Provides:   pki-kra-theme = %{version}-%{release}
    Provides:   pki-kra-ui = %{version}-%{release}

cmake,
java-devel > = 1:1.6.0,
jpackage-utils

dogtag-pki-common-theme = %{version}-%{release}

dogtag-pki-ocsp-theme

User interface "flavor" for pki-ocsp component:

    Conflicts:   redhat-pki-ocsp-theme
    Conflicts:   redhat-pki-ocsp-ui
    Obsoletes:   ipa-pki-ocsp-theme <= 9999
    Provides:   ipa-pki-ocsp-theme = %{version}-%{release}
    Obsoletes:   dogtag-pki-ocsp-ui <= 9
    Provides:   pki-ocsp-theme = %{version}-%{release}
    Provides:   pki-ocsp-ui = %{version}-%{release}

cmake,
java-devel > = 1:1.6.0,
jpackage-utils

dogtag-pki-common-theme = %{version}-%{release}

dogtag-pki-ra-theme

User interface "flavor" for ra component:

    Conflicts:   redhat-pki-ra-theme
    Conflicts:   redhat-pki-ra-ui
    Obsoletes:   ipa-pki-ra-theme <= 9999
    Provides:   ipa-pki-ra-theme = %{version}-%{release}
    Obsoletes:   dogtag-pki-ra-ui <= 9
    Provides:   pki-ra-theme = %{version}-%{release}
    Provides:   pki-ra-ui = %{version}-%{release}

cmake,
java-devel > = 1:1.6.0,
jpackage-utils

 

dogtag-pki-tks-theme

User interface "flavor" for pki-tks component:

    Conflicts:   redhat-pki-tks-theme
    Conflicts:   redhat-pki-tks-ui
    Obsoletes:   ipa-pki-tks-theme <= 9999
    Provides:   ipa-pki-tks-theme = %{version}-%{release}
    Obsoletes:   dogtag-pki-tks-ui <= 9
    Provides:   pki-tks-theme = %{version}-%{release}
    Provides:   pki-tks-ui = %{version}-%{release}

cmake,
java-devel > = 1:1.6.0,
jpackage-utils

dogtag-pki-common-theme = %{version}-%{release}

dogtag-pki-tps-theme

User interface "flavor" for pki-tps component:

    Conflicts:   redhat-pki-tps-theme
    Conflicts:   redhat-pki-tps-ui
    Obsoletes:   ipa-pki-tps-theme <= 9999
    Provides:   ipa-pki-tps-theme = %{version}-%{release}
    Obsoletes:   dogtag-pki-tps-ui <= 9
    Provides:   pki-tps-theme = %{version}-%{release}
    Provides:   pki-tps-ui = %{version}-%{release}

cmake,
java-devel > = 1:1.6.0,
jpackage-utils

 

dogtag-pki-console-theme

User interface "flavor" for pki-console component:

    Conflicts:   redhat-pki-console-theme
    Conflicts:   redhat-pki-console-ui
    Obsoletes:   ipa-pki-console-theme <= 9999
    Provides:   ipa-pki-console-theme = %{version}-%{release}
    Obsoletes:   dogtag-pki-console-ui <= 9
    Provides:   pki-console-theme = %{version}-%{release}
    Provides:   pki-console-ui = %{version}-%{release}

cmake,
java-devel > = 1:1.6.0,
jpackage-utils

java >= 1:1.6.0

'pki-core' (svn+ssh://svn.fedorahosted.org/svn/pki/trunk/pki)

pki-setup

Perl scripts intended for management of CA, DRM, OCSP, RA, TKS, and TPS subsystem instances

cmake,
java-devel >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6-17,
ldapjdk,
nspr-devel,
nss-devel,
openldap-devel,
osutil,
pkgconfig,
policycoreutils,
selinux-policy-devel,
tomcatjss >= 6.0.0,
velocity,
xalan-j2,
xerces-j2

perl-Crypt-SSLeay,
policycoreutils,
openldap-clients

pki-symkey

A Java Native Interface (JNI) library composed of symmetric key functions

cmake,
java-devel >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6-17,
ldapjdk,
nspr-devel,
nss-devel,
openldap-devel,
osutil,
pkgconfig,
policycoreutils,
selinux-policy-devel,
tomcatjss >= 6.0.0,
velocity,
xalan-j2,
xerces-j2

java >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6-17,
nss

pki-native-tools

Various stand-alone PKI tools created from C, C++, Perl, bash, etc.

cmake,
java-devel >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6-17,
ldapjdk,
nspr-devel,
nss-devel,
openldap-devel,
osutil,
pkgconfig,
policycoreutils,
selinux-policy-devel,
tomcatjss >= 6.0.0,
velocity,
xalan-j2,
xerces-j2

openldap-clients,
nss,
nss-tools

pki-util

Low-level PKI utilities

cmake,
java-devel >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6-17,
ldapjdk,
nspr-devel,
nss-devel,
openldap-devel,
osutil,
pkgconfig,
policycoreutils,
selinux-policy-devel,
tomcatjss >= 6.0.0,
velocity,
xalan-j2,
xerces-j2

java >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6-17,
ldapjdk,
osutil

pki-util-javadoc

'pki-util' Javadocs.

  pki-util = %{version}-%{release}

pki-java-tools

Various PKI tools created as stand-alone Java applications.

cmake,
java-devel >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6-17,
ldapjdk,
nspr-devel,
nss-devel,
openldap-devel,
osutil,
pkgconfig,
policycoreutils,
selinux-policy-devel,
tomcatjss >= 6.0.0,
velocity,
xalan-j2,
xerces-j2

java >= 1:1.6.0,
pki-native-tools = %{version}-%{release},
pki-util = %{version}-%{release}

pki-java-tools-javadoc

'pki-java-tools' Javadocs.

  pki-java-doc = %{version}-%{release}

pki-common

Common PKI functions shared by the CA, DRM, OCSP, and TKS subsystems

cmake,
java-devel >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6-17,
ldapjdk,
nspr-devel,
nss-devel,
openldap-devel,
osutil,
pkgconfig,
policycoreutils,
selinux-policy-devel,
tomcatjss >= 6.0.0,
velocity,
xalan-j2,
xerces-j2

apache-commons-lang,
apache-commons-logging,
java >= 1:1.6.0,
jss >= 4.2.6-17,
pki-common-theme >= 9.0.0,
pki-java-tools = %{version}-%{release},
pki-setup = %{version}-%{release},
pki-symkey = %{version}-%{release},
tomcatjss >= 6.0.0,
%{_javadir}/ldapjdk.jar,
%{_javadir}/velocity.jar,
%{_javadir}/xalan-j2.jar,
%{_javadir}/xalan-j2-serializer.jar,
%{_javadir}/xerces-j2.jar,
%{_javadir}/xml-commons-apis.jar,
%{_javadir}/xml-commons-resolver.jar,
velocity

pki-common-javadoc

'pki-common' Javadocs.

  pki-common = %{version}-%{release}

pki-selinux

Selinux policies used by the PKI components.

cmake,
java-devel >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6-17,
ldapjdk,
nspr-devel,
nss-devel,
openldap-devel,
osutil,
pkgconfig,
policycoreutils,
selinux-policy-devel,
tomcatjss >= 6.0.0,
velocity,
xalan-j2,
xerces-j2

policycoreutils,
selinux-policy-targeted

pki-ca

Certificate Authority

cmake,
java-devel >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6-17,
ldapjdk,
nspr-devel,
nss-devel,
openldap-devel,
osutil,
pkgconfig,
policycoreutils,
selinux-policy-devel,
tomcatjss >= 6.0.0,
velocity,
xalan-j2,
xerces-j2

java >= 1:1.6.0,
pki-ca-theme >= 9.0.0,
pki-common = %{version}-%{release},
pki-selinux = %{version}-%{release},
initscripts

Requires(post):   chkconfig
Requires(preun):   chkconfig
Requires(preun):   initscripts
Requires(postun):   initscripts

pki-silent

Java utility used for batch configuration of CA, DRM, OCSP, TKS, RA, and TPS subsystem instances

cmake,
java-devel >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6-17,
ldapjdk,
nspr-devel,
nss-devel,
openldap-devel,
osutil,
pkgconfig,
policycoreutils,
selinux-policy-devel,
tomcatjss >= 6.0.0,
velocity,
xalan-j2,
xerces-j2

java >= 1:1.6.0,
pki-common = %{version}-%{release}

pki-core-debuginfo

'pki-core' subpackage for debugging containing symbols for 'pki-symkey' and 'pki-native-tools'

   
'pki-kra' (svn+ssh://svn.fedorahosted.org/svn/pki/trunk/pki)

pki-kra

Data Recovery Manager

cmake,
java-devel >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6-17,
nspr-devel,
nss-devel,
pki-common,
pki-util

java >= 1:1.6.0,
pki-common,
pki-kra-theme,
pki-selinux,
initscripts

Requires(post):   chkconfig
Requires(preun):   chkconfig
Requires(preun):   initscripts
Requires(postun):   initscripts
'pki-ocsp' (svn+ssh://svn.fedorahosted.org/svn/pki/trunk/pki)

pki-ocsp

Online Certificate Status Protocol Manager

cmake,
java-devel >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6-17,
nspr-devel,
nss-devel,
pki-common,
pki-util

java >= 1:1.6.0,
pki-common,
pki-ocsp-theme,
pki-selinux,
initscripts

Requires(post):   chkconfig
Requires(preun):   chkconfig
Requires(preun):   initscripts
Requires(postun):   initscripts
'pki-ra' (svn+ssh://svn.fedorahosted.org/svn/pki/trunk/pki)

pki-ra

Registration Authority

cmake,
nspr-devel,
nss-devel

mod_nss >= 1.0.8,
mod_perl >= 1.99_16,
mod_revocator >= 1.0.3,
pki-native-tools,
pki-ra-theme,
pki-selinux,
pki-setup,
perl-DBD-SQLite,
sqlite,
/usr/sbin/sendmail,
initscripts

Requires(post):   chkconfig
Requires(preun):   chkconfig
Requires(preun):   initscripts
Requires(postun):   initscripts
'pki-tks' (svn+ssh://svn.fedorahosted.org/svn/pki/trunk/pki)

pki-tks

Token Key Service for Smartcards

cmake,
java-devel >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6-17,
nspr-devel,
nss-devel,
pki-common,
pki-util

java >= 1:1.6.0,
pki-common,
pki-selinux,
pki-tks-theme,
initscripts

Requires(post):   chkconfig
Requires(preun):   chkconfig
Requires(preun):   initscripts
Requires(postun):   initscripts
'pki-tps' (svn+ssh://svn.fedorahosted.org/svn/pki/trunk/pki)

pki-tps

Token Processing System for Smartcards

cmake,
apr-devel,
apr-util-devel,
cyrus-sasl-devel,
httpd-devel,
openldap-devel,
nspr-devel,
nss-devel,
pcre-devel,
svrcore-devel,
zlib,
zlib-devel

mod_nss,
mod_perl,
mod_revocator,
openldap-clients,
perl-Mozilla-LDAP,
pki-native-tools,
pki-selinux,
pki-setup,
pki-tps-theme,
initscripts

Requires(post):   chkconfig
Requires(preun):   chkconfig
Requires(preun):   initscripts
Requires(postun):   initscripts

pki-tps-debuginfo

'pki-tps' subpackage for debugging.

   
'pki-console' (svn+ssh://svn.fedorahosted.org/svn/pki/trunk/pki)

pki-console

PKI console for management of the CA, DRM, OCSP, and TKS subsystems

cmake,
idm-console-framework,
java-devel >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6-17,
ldapjdk,
nspr-devel,
nss-devel,
pki-util

idm-console-framework,
java >= 1:1.6.0,
jss >= 4.2.6-17,
ldapjdk,
pki-console-theme

'dogtag-pki' (svn+ssh://svn.fedorahosted.org/svn/pki/trunk/pki)

dogtag-pki

Meta package used for convenient installation of all 'dogtag-pki' "flavored" services:

    Obsoletes:   ipa-pki
    Conflicts:   redhat-pki
 

jss >= 4.2.6-17,
osutil >= 2.0.1,
tomcatjss >= 6.0.0,
jss-javadoc >= 4.2.6-17,
dogtag-pki-ca-theme >= 9.0.0,
dogtag-pki-common-theme >= 9.0.0,
dogtag-pki-console-theme >= 9.0.0,
dogtag-pki-kra-theme >= 9.0.0,
dogtag-pki-ocsp-theme >= 9.0.0,
dogtag-pki-ra-theme >= 9.0.0,
dogtag-pki-tks-theme >= 9.0.0,
dogtag-pki-tps-theme >= 9.0.0,
pki-ca >= 9.0.0,
pki-common >= 9.0.0,
pki-java-tools >= 9.0.0,
pki-native-tools >= 9.0.0,
pki-selinux >= 9.0.0,
pki-setup >= 9.0.0,
pki-silent >= 9.0.0,
pki-symkey >= 9.0.0,
pki-util >= 9.0.0,
pki-common-javadoc >= 9.0.0,
pki-java-tools-javadoc >= 9.0.0,
pki-util-javadoc >= 9.0.0,
pki-kra >= 9.0.0,
pki-ocsp >= 9.0.0,
pki-ra >= 9.0.0,
pki-tks >= 9.0.0,
pki-tps >= 9.0.0,
pki-console >= 9.0.0,
esc >= 1.1.0


The following table lists the PKI "support" component packages which are separately managed by various members of the PKI team with a brief description of their purpose along with their Fedora build and runtime dependencies:

PKI Support Component Description Fedora Build Dependencies Fedora Runtime Dependencies
'osutil' (ssh://git.fedorahosted.org/git/osutil.git)

osutil

A Java Native Interface (JNI) library composed of operating system utilities - PKI subsystems only utilize the various Base64 and getpid() functions

cmake,
java-devel >= 1:1.6.0,
jpackage-utils,
nspr-devel,
nss-devel,
pkgconfig

java >= 1:1.6.0,
jpackage-utils,
nss

osutil-debuginfo

'osutil' subpackage for debugging.

   
'tomcatjss' (svn+ssh://svn.fedorahosted.org/svn/tomcatjss/trunk/tomcatjss)

tomcatjss

A Java Secure Socket Extension (JSSE) implementation using Java Security Services (JSS) for Tomcat 6.

    Conflicts:   tomcat-native

ant,
java-devel >= 1:1.6.0,
jpackage-utils,
tomcat6 >= 6.0.30-6,
jss >= 4.2.6-17

java >= 1:1.6.0,
jpackage-utils,
tomcat6 >= 6.0.30-6,
jss >= 4.2.6-17

Dogtag 1.3 and Earlier

IMPORTANT: For ALL of the following components, "{flavor}" equals "dogtag"!

The following table lists all PKI component packages with a brief description of their purpose along with their Fedora/EPEL build and runtime dependencies:

PKI Component Description Fedora/EPEL Build Dependencies Fedora/EPEL Runtime Dependencies

osutil

A Java Native Interface (JNI) library composed of operating system utilities - PKI subsystems only utilize the various Base64 and getpid() functions

ant,
java-devel >= 1:1.6.0,
jpackage-utils,
nspr-devel >= 4.6.99,
nss-devel >= 3.12.3.99,
pkgconfig

java >= 1:1.6.0,
jpackage-utils,
nss >= 3.12.3.99

osutil-debuginfo

'osutil' subpackage for debugging.

   

pki-symkey

A Java Native Interface (JNI) library composed of symmetric key functions

NOTE:   Prior to Dogtag 1.3, the 'pki-symkey' RPM was simply called 'symkey' and contained no subpackages!

ant,
java-devel >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6,
nspr-devel >= 4.6.99,
nss-devel >= 3.12.3.99,
pkgconfig

java >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6,
nss >= 3.12.3.99

pki-symkey-debuginfo

'pki-symkey' subpackage for debugging.

   

pki-native-tools

Various stand-alone PKI tools created from C, C++, Perl, bash, etc.

cyrus-sasl-devel,
mozldap-devel,
nspr-devel >= 4.6.99,
nss-devel >= 3.12.3.99,
svrcore-devel

mozldap-tools,
nss >= 3.12.3.99,
nss-tools >= 3.12.3.99

pki-native-tools-debug

'pki-native-tools' subpackage for debugging.

   

pki-util

Low-level PKI utilities

ant,
java-devel >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6,
ldapjdk,
osutil,
xerces-j2

java >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6,
ldapjdk

pki-util-javadoc

'pki-util' Javadocs.

  %{name} = %{version}-%{release}

pki-setup

Perl scripts intended for management of CA, DRM, OCSP, RA, TKS, and TPS subsystem instances

ant

perl-Crypt-SSLeay,
policycoreutils,
%{?fc11:policycoreutils-python},
%{?fc12:policycoreutils-python}

pki-java-tools

Various PKI tools created as stand-alone Java applications.

ant,
java-devel >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6,
osutil,
pki-util

java >= 1:1.6.0,
pki-native-tools,
pki-util

pki-java-tools-javadoc

'pki-java-tools' Javadocs.

  %{name} = %{version}-%{release}

{flavor}-pki-common-ui

User interface "flavor" for pki-common component
Provides: pki-common-ui

ant

 

pki-common

Common PKI functions shared by the CA, DRM, OCSP, and TKS subsystems

ant,
java-devel >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6,
ldapjdk,
osutil,
pki-symkey,
pki-util,
velocity,
xalan-j2

java >= 1:1.6.0,
jss >= 4.2.6,
osutil,
pki-common-ui,
pki-java-tools,
pki-setup,
pki-symkey,
tomcatjss,
%{_javadir}/ldapjdk.jar,
%{_javadir}/velocity.jar,
%{_javadir}/xalan-j2.jar,
%{_javadir}/xerces-j2.jar,
velocity

pki-common-javadoc

'pki-common' Javadocs.

  pki-common = %{version}-%{release}

{flavor}-pki-console-ui

User interface "flavor" for pki-console component
Provides: pki-console-ui

ant,
java-devel >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6,
ldapjdk

java >= 1:1.6.0,
jss >= 4.2.6,
ldapjdk

pki-console

PKI console for management of the CA, DRM, OCSP, and TKS subsystems

ant,
idm-console-framework,
java-devel >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6,
ldapjdk,
pki-util

idm-console-framework,
java >= 1:1.6.0,
jss >= 4.2.6,
ldapjdk,
pki-console-ui

pki-selinux

Selinux policies used by the PKI components.

ant,
m4,
make,
policycoreutils,
selinux-policy-devel

policycoreutils,
selinux-policy-targeted

pki-silent

Java utility used for batch configuration of CA, DRM, OCSP, TKS, RA, and TPS subsystem instances

ant,
java-devel >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6,
pki-common,
pki-util

java >= 1:1.6.0,
pki-common

{flavor}-pki-ca-ui

User interface "flavor" for pki-ca component
Provides: pki-ca-ui

ant

 

pki-ca

Certificate Authority

ant,
java-devel >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6,
pki-common,
pki-util,
tomcatjss

java >= 1:1.6.0,
pki-ca-ui,
pki-common,
pki-console,
pki-selinux,
pki-silent,
(post):chkconfig,
(preun):chkconfig,
(preun):initscripts,
(postun):initscripts

{flavor}-pki-kra-ui

User interface "flavor" for pki-kra component
Provides: pki-kra-ui

ant

 

pki-kra

Data Recovery Manager

ant,
java-devel >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6,
pki-common,
pki-util,
tomcatjss

java >= 1:1.6.0,
pki-common,
pki-console,
pki-kra-ui,
pki-selinux,
pki-silent,
(post):chkconfig,
(preun):chkconfig,
(preun):initscripts,
(postun):initscripts

{flavor}-pki-ocsp-ui

User interface "flavor" for pki-ocsp component
Provides: pki-ocsp-ui

ant

 

pki-ocsp

Online Certificate Status Protocol Manager

ant,
java-devel >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6,
pki-common,
pki-util,
tomcatjss

java >= 1:1.6.0,
pki-common,
pki-console,
pki-ocsp-ui,
pki-selinux,
pki-silent,
(post):chkconfig,
(preun):chkconfig,
(preun):initscripts,
(postun):initscripts

{flavor}-pki-tks-ui

User interface "flavor" for pki-tks component
Provides: pki-tks-ui

ant

 

pki-tks

Token Key Service for Smartcards

ant,
java-devel >= 1:1.6.0,
jpackage-utils,
jss >= 4.2.6,
pki-common,
pki-util,
tomcatjss

java >= 1:1.6.0,
pki-tks-ui,
pki-common,
pki-console,
pki-selinux,
pki-silent,
(post):chkconfig,
(preun):chkconfig,
(preun):initscripts,
(postun):initscripts

{flavor}-pki-ra-ui

User interface "flavor" for ra component
Provides: pki-ra-ui

ant

 

pki-ra

Registration Authority

ant

mod_nss >= 1.0.7,
mod_perl >= 1.99_16,
mozldap >= 6.0.2,
pki-native-tools,
pki-ra-ui,
pki-selinux,
pki-setup,
pki-silent,
perl-DBD-SQLite,
sendmail,
sqlite,
(post):chkconfig,
(preun):chkconfig,
(preun):initscripts,
(postun):initscripts

{flavor}-pki-tps-ui

User interface "flavor" for tps component
Provides: pki-tps-ui

ant

 

pki-tps

Token Processing System for Smartcards

apr-devel,
apr-util-devel,
cyrus-sasl-devel,
httpd-devel >= 2.2.3,
mozldap-devel,
nspr-devel >= 4.6.99,
nss-devel >= 3.12.3.99,
pcre-devel,
svrcore-devel,
zlib,
zlib-devel

mod_nss >= 1.0.7,
mod_perl,
mozldap,
pki-native-tools,
pki-selinux,
pki-setup,
pki-silent,
pki-tps-ui,
(post):chkconfig,
(preun):chkconfig,
(preun):initscripts,
(postun):initscripts

pki-tps-debuginfo

'pki-tps' subpackage for debugging.

   

pki-tps-devel

Symlinks to the {flavor} Certificate System Token Processing System library files required to link executables.

  %{name} = %{version}-%{release}

{flavor}-pki

Meta package used for convenient installation of all '{flavor}-pki' services.

 

{flavor}-pki-common-ui,
{flavor}-pki-console-ui,
{flavor}-pki-ca-ui,
{flavor}-pki-kra-ui,
{flavor}-pki-ocsp-ui,
{flavor}-pki-ra-ui,
{flavor}-pki-tks-ui,
{flavor}-pki-tps-ui,
pki-ca,
pki-kra,
pki-ocsp,
pki-ra,
pki-tks,
pki-tps,
esc,
pki-common-javadoc,
pki-java-tools-javadoc,
pki-util-javadoc

pki-manage

Perl scripts intended for management of CA, DRM, OCSP, RA, TKS, and TPS subsystems

NOTE:   As of Dogtag 1.3, the 'pki-manage' RPM has been 'discontinued' on Fedora/EPEL platforms in favor of 'yum' and 'yum-utils'!

ant

perl >= 5.8.0

pki-migrate

Pre-built applications created to migrate data between various versions of Certificate System

NOTE:   As of Dogtag 1.3, the 'pki-migrate' RPM has been 'discontinued'!

ant
java-devel >= 1:1.6.0
jpackage-utils

java >= 1:1.6.0