Difference between revisions of "PKI Components Collectively via Subversion"

From Dogtag
Jump to: navigation, search
(Building All PKI Components Collectively as a Group)
(Building All PKI Components Collectively as a Group)
Line 59: Line 59:
 
     27  pki-util-javadoc-1.0.0-1.fc8
 
     27  pki-util-javadoc-1.0.0-1.fc8
 
     28  symkey-1.0.0-1.fc8
 
     28  symkey-1.0.0-1.fc8
 +
 +
In the event that all components have '''not''' been built successfully, please debug the problem using the '''typescript.build_pki''' file, and make the appropriate changes.  Next, run the following two scripts to remove '''default''' instances and the PKI components just built:
 +
 +
    cd src/pki/{flavor}/scripts      where "{flavor}" equals "linux"
 +
    ./remove_default_pki_instances  answering "y" to remove all of the instances
 +
    ./remove_pki_components          answering "n" to acknowledge that no existing instances need be removed

Revision as of 20:45, 14 April 2008

Building PKI Components Collectively via Subversion

Checking out PKI Source Code via Subversion

Follow the instructions to checkout a read-only copy of the PKI source code using subversion:

Building All PKI Components Collectively as a Group

In order to build all PKI components collectively as a group, the sudo executable must be available on the development machine. If present, then all PKI components can be built collectively through the use of two scripts, prepare_pki and build_pki, by becoming the root user and adding the following two lines to the /etc/sudoers file:

{username}  ALL = NOPASSWD:       /bin/rpm
{username}  ALL = NOPASSWD:       /usr/bin/yum

First, become the desired {username}, and change directories into the scripts directory:

cd src/pki/{flavor}/scripts      where "{flavor}" equals "linux"

Next, invoke the preparation script to install all PKI support packages:

script -c ./prepare_pki typescript.prepare_pki

NOTE: While the script command is optional, the user may find it useful for debugging purposes.

Finally, issue the following command to build all PKI components:

script -c ./build_pki typescript.build_pki

NOTE: While the script command is optional, the user may find it useful for debugging purposes.

All non-UI PKI RPMs will be created in src/pki/release/pki/base/{component}/dist/rpmpkg/RPMS/{arch} and src/pki/release/pki/base/{component}/dist/rpmpkg/RPMS/noarch, while all PKI UI components will be created in src/pki/release/pki/{flavor}/{component}/dist/rpmpkg/RPMS/noarch. All PKI RPMs will also be automatically installed on the system.


When you have finished, make sure you have all the packages installed:

rpm -qa | egrep -i pki-\|osutil\|symkey | sort | cat -n

You'll see output like this:

    1  osutil-1.0.0-1.fc8
    2  pki-ca-1.0.0-1.fc8
    3  pki-ca-ui-1.0.0-1.fc8
    4  pki-common-1.0.0-1.fc8
    5  pki-common-javadoc-1.0.0-1.fc8
    6  pki-common-ui-1.0.0-1.fc8
    7  pki-console-1.0.0-1.fc8
    8  pki-console-ui-1.0.0-1.fc8
    9  pki-java-tools-1.0.0-1.fc8
   10  pki-java-tools-javadoc-1.0.0-1.fc8
   11  pki-kra-1.0.0-1.fc8
   12  pki-kra-ui-1.0.0-1.fc8
   13  pki-manage-1.0.0-1.fc8
   14  pki-migrate-1.0.0-1.fc8
   15  pki-native-tools-1.0.0-1.fc8
   16  pki-ocsp-1.0.0-1.fc8
   17  pki-ocsp-ui-1.0.0-1.fc8
   18  pki-ra-1.0.0-1.fc8
   19  pki-ra-ui-1.0.0-1.fc8
   20  pki-setup-1.0.0-1.fc8
   21  pki-silent-1.0.0-1.fc8
   22  pki-tks-1.0.0-1.fc8
   23  pki-tks-ui-1.0.0-1.fc8
   24  pki-tps-1.0.0-1.fc8
   25  pki-tps-ui-1.0.0-1.fc8
   26  pki-util-1.0.0-1.fc8
   27  pki-util-javadoc-1.0.0-1.fc8
   28  symkey-1.0.0-1.fc8

In the event that all components have not been built successfully, please debug the problem using the typescript.build_pki file, and make the appropriate changes. Next, run the following two scripts to remove default instances and the PKI components just built:

   cd src/pki/{flavor}/scripts      where "{flavor}" equals "linux"
   ./remove_default_pki_instances   answering "y" to remove all of the instances
   ./remove_pki_components          answering "n" to acknowledge that no existing instances need be removed